Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Grow your Fabric skills and prepare for the DP-600 certification exam by completing the latest Microsoft Fabric challenge.

Recieved 'Could not load file or assembly 'System.Runtime.CompilerServices.Unsafe, Version=4.0.4.1

Hey all, 

Trying to refresh my datasets, but I've received an error:

 

Processing error: An error happened while reading data from the provider: 'Could not load file or assembly 'System.Runtime.CompilerServices.Unsafe, Version=4.0.4.1, Culture=neutral, PublicKeyToken='' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)'
Cluster URI: WABI-US-NORTH-CENTRAL-B-redirect.analysis.windows.net

 

Using PostgreSQL for Azure and using NO gateways. 

This issue was faced before but no info on how it was fixed - https://community.powerbi.com/t5/Service/Could-not-load-file-or-assembly-System-Runtime-CompilerServ...


Any ideas on how this could be fixed? 


Thanks!

 

Status: New
Comments
DataMaru
Advocate II

Same exact issue for me.

andyclap
Helper III

Looks like it's fixed now, thankfully.

 

 

glayman
New Member

I still have not gotten the fix for this issue. Something I am missing? 

peter_werk
Frequent Visitor

Still having issue on 13 September 10 PM CEST 

PakthurYangu
Helper I

I wasted a few days looking for a solution until I came across this article.

In short, you have to install version 4.0.10 of NpgSQL and when installing, select the NpgSQL GAC option. The article I linked has a more detailed step-by-step guide.