Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Grow your Fabric skills and prepare for the DP-600 certification exam by completing the latest Microsoft Fabric challenge.

Query contains unsupported function. Function name: Resource.Access

Hi Team,

 

We are facing the issue with the Powerbi Service from past 2-3 day. we are getting " Query contains unsupported function. Function name: Resource.Access " through the python scripts.Before that we are using the same through the personal gateway installed. Attaching  the image for you refrence.Please Fix this issue ASAP!!

SathishR_0-1670311850535.png

 

Thanks and Regards

Sathish

 

Status: Delivered

Hi @SathishR 

This issue has been fixed . Please check this issue in your Service .

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
matryb
Advocate I
Tomkru
Regular Visitor

I have the same problem. Only with newly published reports. 

To check, I made a copy of a report that I published months ago and is still refreshing without problems. If I publish this exact same report under a different name I get the error mentioned above!

Kronhjort
Frequent Visitor

I have the same problem on and old model, where I made a small change 

mmamfgm
Regular Visitor

I have the same issue

maria_erocha
New Member

Hi, 

 

I Have the same problem, I update a new version of power bi, version Versão: 2.111.590.0 64-bit (novembro de 2022)

 

Maybe Can be this? 

alena2k
Resolver IV

I just got to the same problem with composite dataset. I thought that Direct Connection could be a reason, but nope, I still have this: 
Query contains unsupported function. Function name: Resource.Access

Lineage does not look right for this dataset.

flavia
Advocate II

Hi guys!

take a look at the support website of microsoft power bi, there is a message telling about this issue!

v-yetao1-msft
Community Support
Status changed to: Accepted

Hi @SathishR 

It's a known issue . Engineers are investigating the issue and an update will be provided soon. Please be patient .

Ailsamsft_0-1670377417947.png

Best Regards,
Community Support Team _ Ailsa Tao

semmmadli
Regular Visitor

I am facing the same issue with recently published repots. Old reports are uptading without any problem

Juergen_Koller
Regular Visitor

FYI: Same issue with a custom connector as data source.

Is there maybe a problem with the translations from the resource file?