Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Privacy Level setting is reset in Data Gateway after failed attempt to set up a dataflow

Privacy setting for a data source in the data gateway is reset to "None" whenever I cancel a process of setting up a dataflow entity with the data source and the gateway. I have not been successful in setting up a connection with any data sources at this time, so I do not know what would happen if I DON'T cancel the process. I am able to recreate the condition every time. This appears to be a bug, but I would like a confirmation that I am not doing something wrong to cause this.

Status: New
Comments
v-qiuyu-msft
Community Support

Hi @DP86,

 

I'm not very clear about the issue, would you please share more information, eg: detail steps to reproduce the issue, some screenshots? 

 

You can take a look at this article to learn how to create a dataflow entity: https://docs.microsoft.com/en-us/power-bi/service-dataflows-create-use

 

By the way, please ensure you are running the latest on-premise data gateway.  

 

Best Regards,
Qiuyun Yu 

Anonymous
Not applicable

This same exact thing is happening to me. All of my gateway data sources are set to organizational. Whenever I try to create a dataflow off of one of these sources it resets the gateway privacy level setting to none and the next time all of our production reports refresh, they fail. I have yet to actually save a dataflow for these affected data sets so I also cannot confirm if this happens when the dataflow is fully set up. 

 

I would love to take advantage but right not even experimenting with them is causing production issues which is a huge barrier to testing them.

 

 

DP86
Advocate II

Qiuyun Yu,

The following are my steps:

 

  • This is what it looks like in the Gateway before the process:
    Before.png
  • Step 1:
    Step1.png
  • Step 2:
    Step2.png
  • Step 3:
    This is where it errors out for some reason.
    Step3.png
  • Now the Gateway looks like this:
    After.png
    The privacy level can easily be manually set to the original state, but 

I hope this helps you understand the condition.

Let me know if I need to suppy more information.

v-qiuyu-msft
Community Support

Hi all, 

 

I have reported this issue internally: CRI 94422090. Will update here once I get any information. 

 

Best Regards,
Qiuyun Yu 

v-qiuyu-msft
Community Support

Hi all, 

 

The fix should be released around January 5th. 

 

Best Regards,

Qiuyun Yu 

v-yuta-msft
Community Support

@DP86 ,

 

This issue has been fixed currently.

 

Regards,

Jimmy Tao