Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

PowerBI Settings -> Datamarts (Preview) -> Data source credentials -> Edit credentials always fails

It is not possible to edit credentials for (at least) AzureDataExplorer data sources. Any attempt to do so will give a popup like:

siredman_0-1680112238699.png

 

In which the Authentication method box is not populated. There are no options in the Authentication method dropdown.

 

Attempting to submit the dialogue will return a 400 error:

error: {code: "BadRequest", message: "Bad Request",…}
code: "BadRequest"
details: [{message: "The CredentialType field is required.", target: "request.CredentialType"}]
message: "Bad Request"

Status: Needs Info

Hi @siredman 

Can you connect AzureDataExplorer in Desktop or dataset ? When did this happen? Was it possible to edit normally before?

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
v-yetao1-msft
Community Support
Status changed to: Needs Info

Hi @siredman 

Can you connect AzureDataExplorer in Desktop or dataset ? When did this happen? Was it possible to edit normally before?

 

Best Regards,
Community Support Team _ Ailsa Tao

siredman
Employee

Hi @v-yetao1-msft ,

Yesterday was my first time trying this feature, so I am not sure whether it was possible to do this at any point before.

I can connect to AzureDataExplorer correctly in web and desktop, but I cannot configure this connection in the Datamart.

 

Thanks,

Simon

siredman
Employee

To clairify, by "web" above, I mean I can connect to AzureDataExplorer using https://dataexplorer.azure.com/ and manually run queries.

I just confirmed that I am able to connect to AzureDataExplorer in PowerBI desktop and from there I am able to modify the privacy settings.

When I try to create a DataSet in the PowerBI Service, I do not have the option to use AzureDataExplorer as a source:

siredman_0-1680189272950.png


I created a new v1 DataFlow and connected AzureDataExplorer to the same Kusto cluster and database, and in the DataFlow I am able to configure the connection settings:

siredman_1-1680189536737.png
Thanks,
Simon