Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Power BI service does not render reports consistently

I have a report that have 4 matrix visualisations on it. If I open a browser on my monitor screen (1920 X 1080), then open the report there are no scroll bars on any of the matrix visualisations. However, if I open a browser on my laptop screen (1920 X 1080), then open the report there are scroll bars on some of the matrix visualisations. 


It doesn’t matter which browser I use (I’ve tried Firefox, Chrome, and Edge) it’s the same, scroll bars only on the laptop screen. The screen resolutions are the same (1920 x 1080); it’s the same machine, a laptop with an external monitor. If I drag the browser from the monitor screen to the laptop screen there are no scroll bars, the scroll bars are not needed to make the data fit, but if I refresh the browser, they come back. I have tried it on different laptops with different external monitors and the same things happens. 

 

It would appear that the Power BI Service is not using the the layout set in Power BI Desktop, it just uses it as an guide. With the Power BI service working like this I can't use it for public facing reports as I dont know what they are going to see, and I'm not sure internal users will like it much either.

 

I have tried to make the visual bigger but there doesnt appear to be any logic as to whihc screens will have scroll bars. I have to make the visual a bit bigger, publish it, then view it on the differnt laptop screens we have, all with the same resolution, as it wil be scroll bar free on some, but will have scroll bars on others. I then have to repeat untill its scroll bar free on all screens, and some screens will have space around the visuals and some won't.

 

I’ve attached screen shots from the monitor screen and the laptop screen so you can see the issuelaptop screen.jpgmonitor screen.jpg

Status: Needs Info

Hi @JohnKNis 

If you open it on another computer, is there a scroll bar as well ?

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
v-yetao1-msft
Community Support
Status changed to: Needs Info

Hi @JohnKNis 

If you open it on another computer, is there a scroll bar as well ?

 

Best Regards,
Community Support Team _ Ailsa Tao

JohnKNis
Frequent Visitor

Hi @v-yetao1-msft 

 

The actual computer doesnt matter, it depends on the screen. On desktops we dont get scroll bars as they all have 22" monitors, but on laptops (if opened on the laptop screen) we do get scroll bars but if opened on a connected 22" monitor we dont get scroll bars. Its been tried on several laptops and the make and model of the laptop doesnt matter, and nether does the way its connected to a monitod, via a docking station or direct.

 

The only thing that appears to matter is the physical size of the screen, most of our laptops are 14" models and they all show scroll bars when opened on the laptop screen, but on the few 17" models we have there are no scroll bars when opened on the laptop screen. 

 

a few other things that might be usefull.

It doesnt just affect the Matrix visualisation, others are also affected by the same issue

The exact same thing (same scroll bars on same visualisations blocking the same data) happens when opening the report on iPads/iPhones and andriod tables and phones. when viewd on the web and via the app

akhilduvvuru
Advocate II

Team, I'm also facing the same issue with Table visual.

 
Just wanted to know if you find any fix
 
I have a report which has only one page with one table visual perfectly fit without having horizontal or vertical scroll. All looks good on the Power BI Desktop. However, after I publish the same report to service, I'm starting to see both horizontal and vertical scroll in the table visual (not for the page).
 
Observations:
  1. I use a Macbook. As Power BI desktop doesn't support Mac, I installed PBI desktop app on the remote desktop to create reports. After publishing the report to Power BI Service, if I open the report in Macbook (outside remote desktop) using Google Chrome I'm seeing the scroll (both vertical and horizantal). But if I open the same report in the remote desktop using Google Chrome, I don't see any scroll.
  2. I also tried checking with Microsoft Edge browser, I don't see scroll in remote desktop but I see scroll (both vertical and horizantal) in Mac.
  3. If I open the same report using Safari browser, I don't see any scroll. Report is absolutely working well. 
I tried checking the same with my colleagues and they are also facing the same issue when they open the same report.
 
I don't understand what exactly is going wrong. Is it something related to the browser or report or laptop? I'm not sure. 
 
As Google Chrome is one of the most widely used browser, I want to make sure this report works properly in Chrome. 
 
Can someone please help me if you hear this or experience this issue previously. Awaiting your response!
 
Chrome in Remote Desktop.pngSafari Browser.pngChrome in Mac.png
akhilduvvuru
Advocate II

@v-yetao1-msft  - I'm also facing the same issue like explained in my above comment and this community post . Do you have any fix/workaround/trick/hack for this issue?

 

https://community.powerbi.com/t5/Service/Scroll-bar-issue-when-report-open-Chrome-Edge-browser/m-p/3...

 

Thanks!