Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Power BI reports taking ages to publish and getting frequent "contact the owner of this workspace"

Since this morning we are having massive difficulty publishing reports to our workspaces. There are a number of reports, both with live data sources or "presentation" ones based on static spreadsheets over various workspaces. Regardless of the data source or complexity of the models they are taking anywhere between 30 minutes to an hour or more to publish if they publish at all. We have also frequently been receiving an error saying we cannot publish to a workspace please contact the admin/owner (that would be me!) I've check and the workspace login matches my PBI login. Also logged out of both and back in again to make sure it wasn't that, also, my colleague is having the same problems and has done the same thing. The reports we're working on were the same that, yesterday, were publishing in a few minutes (let's say 3 minutes max for the most complex). I spoke to our IT guys and they haven't made any changes or noticed anything out of the ordinary and the changes we've made are little more than cosmetic so should not result in such a sharp increase in upload time. Please could you let us know if there is anything else we can do from our end to identify the cause?

Status: Needs Info
Not applicable

Also having issues in the UK. Raised a ticket with Microsoft but not heard anything back yet. Not great for a Premium paying customer!

Microsoft Employee

@wjeanes @mbrough ,

I am unable to reproduce this issue on my side.  Do you still get this issue? I suspect that it is a temporary issue.


Microsoft Employee
Status changed to: Needs Info
Advocate III

@v-yuezhe-msft thanks for getting back about this.  I tried to publish again this morning and the issue seems to have sorted itself out as the report literally took a minute to publish.  I note that a number of our automatic rehreshes failed last night due to timeout issues which we haven't come across to date however I was able to refresh and manually republish this morning (SAST, so it may have self corrected before you were able to test)


@Anonymous we're on similar timezones so I hope the issue is sorted out for you now as well.

Advocate I

Same here in Sweden. Seems impossible to overwrite existing reports/datasets. First have to remove them in order to publish successfully. 

Frequent Visitor

I've been having this same issue throughout the day today - seems impossible to overwrite existing datasets as tomkvarby points out. By removing it first from the cloud, it finally uploads.



This work around is not working! in my case as the report is linked to number of Teams in MS Teams - the links will be lost when the dataset is deleted. Additionally view metrics will also be lost (as 'new report' is uploaded).


Not applicable

I'm having the same issue today as well. It's trying to publish for around 30 minutes and throws an error message the same as thread starter had. I am also admin of the workspace and this has been working as expected (publishing in around a few seconds) before today.

Not applicable

@v-yuezhe-msft The issue is not resolved. We are facing issue here in Norway with any online data source. unable to publish or connect to any online data source. Please revert at earliest.

Not applicable

Yep... add me to the list. Has been erratic the past week or so but this morning haven't been able to publish anything *at all*. 

As has been said - seems fine if the dataset isn't already in the workspace you want to publish to, but doesn't work if you're trying to overwrite one, which is what we want to do. 

Frequent Visitor

Today has been horrific - unable to publish any of my reports to our 2 workspaces.  Just constantly hangs at "Publishing...."


What's going Microsoft - as a Premium customer as well, this is wholly disappointing.