Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Power BI Gateway Users Blank & Manage Users Stuck on Loading

With the debut of the new UX there seems to be some problem with the "Manage Connections and Gateways" experience's interaction with the users component. When you I view the Connections tab, the entire "Users" column is blank. When I go into "Manage Users" for a particular connection, the users list stays stuck on "Loading" and searching for known users returns no results, even if you provide the full user email address. This is true despite a fresh browser session in Edge or testing with an InPrivate window. Interestingly this is a problem only for the Gateways management UX, it's not a problem for Workspace Access for example. 

equerystrian_0-1684961999523.png  

equerystrian_1-1684962200496.png

 

 

This kind of issue seems to have happened before and the workaround was going to the old UX. It worked for me in a pinch today but hopefully this issue will be resolved quickly. Cannot access Manage users setting in Gateway - Microsoft Fabric Community

 

Status: Investigating

Hi  @equerystrian ,

 

Since the implementation schedule of PowerBI version varies from region to region, can you provide detailed version information for us to do better troubleshooting?
It is available in about Power BI in the upper right corner of Power BI Service.

 

Best regards.
Community Support Team_Caitlyn

Comments
v-xiaoyan-msft
Community Support
Status changed to: Investigating

Hi  @equerystrian ,

 

Since the implementation schedule of PowerBI version varies from region to region, can you provide detailed version information for us to do better troubleshooting?
It is available in about Power BI in the upper right corner of Power BI Service.

 

Best regards.
Community Support Team_Caitlyn

equerystrian
Advocate I

Here is the information on our tenant, minus the actual Tenant URL

 

Service version:13.0.20726.75
Client version:2305.3.14047-train
Activity ID:42895e30-bb29-46dd-b5fa-f5f8132aaa42
App Instance ID:qlnc7
Your data is stored in North Central US (Illinois)
Thu May 25 2023 09:09:34 GMT-0400 (Eastern Daylight Time)
zyliu2023
New Member

zyliu2023_0-1685750854669.png

Facing exact same issue on 03/Jun/2023

 

MattPennerVV
Regular Visitor

Facing the same issue. Occurs both in Chrome and Edge (both latest versions).

MattPennerVV_0-1686944863786.png

 

robekr
Advocate I

We also experience the same issue. Users that have access doesn't show on the data source page. And when opening the Settings page, it just hangs on "Loading"

 

Service version:13.0.20913.58
Client version:2306.2.14324-train
Activity ID:65a29d2d-ebfa-4dc7-acf1-209e4b613767
App Instance ID:t3av9

 

robekr_0-1687420700855.png

 

MattPennerVV
Regular Visitor

Found a solution.

 

I spent 30 minutes on a support call with Microsoft and the agent eventually confirmed this was a bug, most likely introduced during the recent roll out of Fabric.  

 

However, he did show me that you can administer gateways from the Power Apps admin center, which I hadn't realized.  And it works as expected:

https://admin.powerplatform.microsoft.com/ext/DataGateways

 

Strangely, since then it seems that my gateway administration area of Power BI is now working correctly also.  Not sure if they just released a fix and if it might take time to roll out to all customers.

 

Hope this helps.