On-Premises Data Gateway gets disconnected/offline
The On-Premises Data Gateway gets disconnected all of the sudden throwing the error - "The data source is inaccessible because the gateway is unreachable". And even if we try to restart the services, it gets stuck and shows - "Windows could not stop the on-premises data gateway services on local computer" and after couple minutes it stops responding.
To start the on-premises data gateway again, we need to first end the on-premises task from the task manager and then again start the On-Premises Data Gateway services. It will run smoothly for some time but it'll again get stuck with the same issue described above.
FYI - we have the latest version of On-Premises Data Gateway - October 2021
1 Comment
- v-robertq-msft
Community Support
Status changed:NewtoInvestigatingHi,
I think you should first check if the crash down of the on-premise gateway is due to the large resource consumption. As a result, your local computer has no remaining resources to run this service. You can go to the task manager to check:
What’s more, if you still have a problem, I suggest you to uninstall the gateway from your PC to install the latest version again and restore the original gateway to it:
https://docs.microsoft.com/en-us/data-integration/gateway/service-gateway-migrate
Thank you very much!
Best Regards,
Community Support Team _Robert Qin