Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Not Able to Pin Visuals to Dashboard

Starting today I have been unable to pin most Power BI visualizations to any dashboards. This includes KPI cards, graphs, etc. but not data cards.

The pin button is available at the top right of each visualization, but when I click it, there is no preview on the left hand side to show what the pinned visual will look like. Then when I click the yellow "Pin" button, nothing happens (i.e. window does not close & no confirmation that the visual has been added with link to go to dashboard).

This issue occurs for all my workspaces including "My Workspace". Is there any reason for this?

I have tried deleting and republishing the report and dataset, as well as logging out of my Power BI account.

 

PowerBI_PinIssue.png

Preview missing on left hand side

Status: Accepted

Hi @reyesjon 

It's a known issue . The ID is 346379883 . 

Tested workaround : in power bi service edit mode untoggle title and retoggle title and save the report then we can pin the tile to dashboard .

The problem is being fixed, I will come back and update if there is any progress .

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
Anonymous
Not applicable

I had same problem.  Turning off the Title and then on again, and republishing worked for my new ones. 

I do not see this mentioned above, but I had a bunch of that kind of tile that were already on Dashboards that I notice had stopped refreshing for me (and manual refreshes of underlying reports did not help).   I had to remove each impacted tile and re-add following the same 'remove title, re-add title' process.   I haven't yet confirmed that they are now updating again. 

TonyRama_CA
Regular Visitor

I had same problem.  Turning off the Title and then on again, and republishing worked for my new ones. 


True. For my title-less tables, I edited the live reports, toggled title ON and saved, toggled OFF then saved. Pinning and copying to clipboard are working now.

 

Thanks for all the insights.

c_pattern
New Member

I had the same issue just today using a scatterplot. I could see the "pin" icon on the visual, but nothing happened when I clicked it. Occasionally, if I clicked it a few times, it would disappear. Other visuals in the same report were not impacted.

 

I toggled off the "Title" of the visual, saved the report, and then I was able to pin successfully.

I then togged the "Title" back on, saved the report, and was yet again able to pin successfully. 

sk_01
Regular Visitor

I have the same issue with combo line/column chart

sk_01_0-1667664583589.png

 

v-yetao1-msft
Community Support
Status changed to: Accepted

Hi @reyesjon 

It's a known issue . The ID is 346379883 . 

Tested workaround : in power bi service edit mode untoggle title and retoggle title and save the report then we can pin the tile to dashboard .

The problem is being fixed, I will come back and update if there is any progress .

 

Best Regards,
Community Support Team _ Ailsa Tao