Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

No handler was found for message type 'Microsoft.Mashup.Evaluator.MessageBasedOutputStream+BinaryChu

I keep running into this issue often. Is there any way to resolve this? How do we even raise a new issue through Power BI community. It only asks for new idea, but I couldn't find "report an issue" button or something like that. Am I missing something here? This UI needs vast revamping interms of userfriendliness. I'm reporting an issue through a 'new idea'.

Feedback Type:
Frown (Error)

Error Message:
No handler was found for message type 'Microsoft.Mashup.Evaluator.MessageBasedOutputStream+BinaryChunkMessage'.

Stack Trace:
Microsoft.Mashup.Host.Document.SerializedException
at Microsoft.Mashup.Evaluator.MessageHandlers.Dispatch(IMessageChannel channel, Message message)
at Microsoft.Mashup.Evaluator.ChannelMessenger.ChannelMessageHandlers.TryDispatch(IMessageChannel channel, Message message)

Status: New
Comments
shadder
New Member

Had this error and just figured out how to fix. In my situation, I had 1-to-many a table relationship established. There were duplicates in the table that was supposed to have unique values. If you have duplicates in a table that should not have duplicates, you might be able to resolve your issues like I just did. Good luck!

jberkey100
Regular Visitor

I tried all of the suggestions here without any luck, but the issue for me ended up being that I was removing the duplicates on the SQL side AND in the Power BI Power Query side, but there was one field (used for relating tables) that had 3 values:

"123456",

"123456000", and

"123456

"

(the last one had a carriage return).

 

Apparently Power BI reads these 3 values as equal when relating the tables, but not on the Power Query side.

BeidiWang
New Member

SAME ERROR CODE, INDIVIDULE TABLE REFRESH, BUT VISUALS DONT. 

thought i had to redo everything. it is desktop version, but turned out to be quick fix, on one lookup table, source file i added another row, this row couldnt be tracked to my data tables, so as soon as i delete the row, everything is back.

ncbf87
Frequent Visitor

Same error, but fixed it. Found extra (blank) rows in one of my table. Once I delete the blank rows from the source data, all good. But agree the error code can be more detailed in helping with troubleshooting

Anonymous
Not applicable

Duplicate values in a table which has one to manay relationship in the data model, is to be blamed here

jpriemer
Advocate I

Hi All, I had a similar issue and was able to find more specific details by clicking the update error icon in Power BI Service. In my case, it was caused by a duplicate item in one of my dimension tables. The error details in Power BI Service detailed the exact column and table that was causing the issue. 

 

The remove duplicates function in query editor is case sensitive but the model in M is not. To resolve, I created a secondary column using Text.Upper([column]) and then removed duplicates on this new column with all upper case text.