Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

No HTML Content - Embed Webpart SharePoint Online

Hello,

 

I have multiple Power BI Dashboards that leverage the HTML Content viewer custom visual ( https://powerbi.tips/2020/10/html-content-custom-visual/ ) from Daniel Marsh-Patrick.

 

The dashboards are currently embedded in SharePoint Online Modern Pages and leverage the Power BI web part.

 

Through Thursday (6/30/22) last week everything was working splendedly. At some point over this past weekend something changed. Data was refreshed on schedule with no errors and while the Dashboards load, no HTML content is displayed.

 

If I hit the Dashboard directly in the Power BI workspace (e.g. app.powerbi.com) the dashboard displays all data correctly.

 

Thanks

 

Display via app.powerbi.com:

 

ecorcor_0-1657039308434.png

 

Display via embed Power BI webpart in SharePoint Online:

ecorcor_1-1657039371914.png

 

 

Status: Delivered

Issue is fixed automatically.

Comments
v-cazheng-msft
Community Support
Status changed to: Investigating

Hi @ecorcor ,

 

If you refresh your browser page or click on the Reset to default or Refresh visuals option, will you see it display correctly?

vcazhengmsft_0-1657077434624.png

 

If you re-embed this dashboard, will you see this issue as well?

 

Best Regards,

Community Support Team _ Caiyun

ecorcor
Regular Visitor

Thank you for the response.

 

Unfortunately, hitting the refresh button in the Power BI embedded action bar OR doing a forced browser (Chrome) refresh by holding down the SHIFT Key while reloading the page does not make the HTML content appear.

 

I don't believe this has anything to do with the client side / browser side settings. As I mentioned this was working fine for several months up until last weekend. Also, I was alerted by several users that they could no longer see the content from their machines as well. All of them can see the content when hitting the dashboard directly in app.powerbi.com.

 

Thanks again.

 

- Tom

ecorcor
Regular Visitor

Update - the embedded dashboard via that Power BI web part just started working and serving the HTML content when I refreshed a test page a few minutes ago.

 

Either this was a transient issue or something was fixed in the past 7 hours.

 

Thanks again for any attention or support provided.

 

- Tom

junhchen
Regular Visitor

I too am seeing the HTML contents working on embed url, thanks!

v-cazheng-msft
Community Support

Hi @ecorcor @junhchen,

 

That's great! Thanks for your reply!

 

Best Regards,

Community Support Team _ Caiyun

v-cazheng-msft
Community Support
Status changed to: Delivered

Issue is fixed automatically.

ecorcor
Regular Visitor

Hello everyone, another update, thanks for monitoring and for the support.

 

As I look at my embeded dashboards in SharePoint pages via the Power BI web part, they are again this morning no longer displaying HTML content.

 

It appears the issue has reappeared between my post yesterday afternoon around 2 PM ET and this morning.

 

Thanks,

 

- Tom