Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

New Google Analytics 4 connector (2.0 beta) issues

Hi,

 

I am testing and converting some Power Bi reports to the new GA4 connector (beta 2.0). There is a bug with the connector when the query has more than 10 000 rows. I am able to build my query from the cube, then the transform data preview works. Howerver, when I press "Close & Apply", the "Load" popup appears and hang at "Evaluating...". If I have less than 10 000 rows, the dataset will load just fine. 

 

The problem is quite easy to reproduce. Just add enough dimensions to produce more than 10 000 rows. I understand this connector is in beta. I want to be sure you know the new connector is actualy unable to load more than then 10 000 rows limit for a single call from the Google GA API. The old connector was able to load more rows. 

 

Another issue with the new GA4 connector (2.0 beta) is that it is accessible from the «New source» button but the «Recent sources» button will always utilize the old implementation. This second issue is much less important than the first one.

 

* I originaly posted this in "Get help with powerbi", but I move it here instead.

 

Thanks,

 

Felix

Status: Accepted

Hi  @felixnicol ,

 

We have seen on the internal platform that other engineers have reported this issue and submitted it.
The engineers on the product team are now aware and will do their best to resolve the issue. I will update here if there is any progress, so please be patient.

 

Best regards.
Community Support Team_Caitlyn

Comments
v-xiaoyan-msft
Community Support
Status changed to: Accepted

Hi  @felixnicol ,

 

We have seen on the internal platform that other engineers have reported this issue and submitted it.
The engineers on the product team are now aware and will do their best to resolve the issue. I will update here if there is any progress, so please be patient.

 

Best regards.
Community Support Team_Caitlyn

dannyfig
Frequent Visitor

Hello @felixnicol, I don not have this issue and have a table with 61 972 rows. Is the issue you reported still happening?

Thanks!

rasmiranjannaya
New Member

I am having the same issue while loading more rows Through GA4 connector(beta 2.0). Need Help.

pz power bi issue.png

folke
New Member

Also encountering this exact same issue. Would be great to get a fix!

QueryWhiz
Helper V

Hi @felixnicol Seems like the 2.0 beta connector is still presenting some issues. I hope it'll be fixed soon. As a workaround, maybe you can try to test your connection with a 3rd party tool. I've tried windsor.ai, supemetrics and funnel.io. I stayed with windsor because it is much cheaper so just to let you know other options. 

Elephant
Frequent Visitor

Having the same issue here.

 

@v-xiaoyan-msft, any idea when this issue will be resolved?

 

It is a major issue for us, as Google Analytics UA (legacy) will be forcibly replaced on July 1st 2024 for GA4, and the 1.0 connector doesn't work with GA4.

 

Can't wait for connector 2.0 not to be Beta anymore!

 

Thanks for keeping us posted