Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Measure Formatting: Direct Query Power BI Data Set

Per the June 2021 Power BI it appears that formatting of measures should flow through to local models when using direct query against a Power BI data set.  Unfortunately, I am not seeing this behavior in my local model that has a direct query against one Power BI data set.  I see the option is in "preview", but don't see anywhere in the options that I need to "check a box" other than for the overall option to activate direct query against power bi data sets.  

LukeSteen_0-1625752806620.png

After the June update new folders did appear with the measure format strings:

LukeSteen_1-1625753867276.png

However, if I go and view the actual measure formatting or use the measure in the report there is no formatting.  Below is a measure that is formatted as % with one decimal in the dataset, but in the local model that direct queries against that data set there is no formatting per the screenshot below:

LukeSteen_2-1625754090686.png

Not sure if I am misunderstanding what the June update addressed, if have not activated this preview feature correctly or if there is a bug.  Any help/guidance would be appreciated.  Here are my preview options:

LukeSteen_3-1625754224833.png

 

Here is the version I have installed:

LukeSteen_4-1625754268543.png

 

 

Thank you in advance!

Luke

 



Status: New
Comments
v-robertq-msft
Community Support

Hi, 

According to your description, I can’t clearly understand the specific happening form of your problem. Does it show the error message when placed in the visuals or just can’t display the correct percentage format?

You can explain it in detail. According to my test, I got this error(I connected to a composite model published to the Power BI service):

vrobertqmsft_0-1625820167148.png

 

https://powerbi.microsoft.com/en-us/blog/power-bi-june-2021-feature-summary/#post-16112-_Toc74044959

 

Thank you very much!

 

Best Regards,

Community Support Team _Robert Qin

LukeSteen
Frequent Visitor

Hi Robert -

 

Thank you for the quick reply and sorry for not being clear/providing all the relevant information.  I dont encounter any error message, it is just that the formatting of the measure does not flow through from the original model to the model that has the direct query against the original model data set.  

 

This is the measure in the original model when dragged into a visual:

LukeSteen_0-1625844706416.png

This is the measure when dragged into the model that has a directquery to the original model data set:

LukeSteen_1-1625844771590.png

 

Thank you again!

 

Luke

v-robertq-msft
Community Support

Hi, 

According to my second test, it seems that my measure in the DQ mode can be correctly converted into the percentage format, here are my screenshots:

vrobertqmsft_0-1626056947978.png

vrobertqmsft_1-1626056947980.png

vrobertqmsft_2-1626056947981.png

vrobertqmsft_3-1626056947984.png

 

I think you can test the problem again and check if if you can just simply change the measure format here and make it work:

vrobertqmsft_4-1626056947986.png

 

Thank you very much!

 

Best Regards,

Community Support Team _Robert Qin

LukeSteen
Frequent Visitor

Thank you Robert.  I have been formatting each measure when I connect a PBX file to a power bi dataset, but my understanding is that the June update would allow the formatting from the dataset that I am connecting with to flow throw into the pbix file, similar to when you use live connect is that not the case?  

alexrobe_RHI
Frequent Visitor

I'd like to Follow up on this, as I have the same behaviour in all me DirectQueryConnection to PowerBI-Datasets which themselves have advanced format string expressions - also with Calculation Groups with Format Expression strings which seem to create those hidden "Format String Measures" display folders.

1. I have a local "model"  with a simple tabel 

2. I connect to a PowerBI Dataset which has advanced format Expression strings.

All the measures are NOT formatted at all

alexrobe_RHI_0-1668711814078.png

Although the measures do have their individual Format Strings: Here an Example for OEE - with the special "Format String Measures" display folder, which seem to appear somehow, as soon as you create Calculation Groups with Format expressions via Tabular Editor :

alexrobe_RHI_4-1668712564515.png

 

3. I go to Tabular Editor to change these format string e.g: for NEE % "#,##0.000%" and Save

alexrobe_RHI_1-1668711997077.png

4. then everything shows up as expected

alexrobe_RHI_2-1668712159411.png

5. If i hit the Refresh button locally, the (empty) Format string seems to be taken again from the external dataset and reverts my local format string I just applied before: 

alexrobe_RHI_3-1668712385307.png

Back to square 1... 

===

So the questions:

  • Why does it not import the Format from the external Dataset?
  • Why is my locally changed Metadata Format String not kept? If I disable "include new tables..." alexrobe_RHI_5-1668712969809.png my local Format strings are kept, but there are continuous enhancements on the external dataset going on which I eventually need
  • Could it have something to do with other not so obvious Power BI settings (e.g. I have Infrastructure Update deactivated...)

 

  • So: any Ideas for settings, workarounds? -> Main goal is to get the source Format Strings to get pushed through

Thanks!

 

ivy8252003
Frequent Visitor

I have the same question here. The new dynamic format strings for measures don't get pushed through neither. Anyone has solutions? 

 

Thanks!