Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Grow your Fabric skills and prepare for the DP-600 certification exam by completing the latest Microsoft Fabric challenge.

Issue in connecting to Azure Cosmos DB

I am facing issue in connecting to the azure cosmos DB from the portal. The connection works in my Power BI Desktop with the same key and the data is getting refreshed.

 

But after publishing the report, the schedule refresh is not working due to credentials error.

 

Error: Failed to update data source credentials: The credentials provided for the DocumentDB source are invalid.

 

The same is working for my Dev Environment, but the production connection fails using the Key.

 

rachebh1_0-1683205091939.png

 

Please help in resolving the issue.

Status: Investigating

Hi @rachebh1 ,

Try to click "skip test connection" when you are doing your data source setting.

vyanjiangmsft_0-1683272049140.png

 

Best regards,

Community Support Team_yanjiang

Comments
v-yanjiang-msft
Community Support
Status changed to: Investigating

Hi @rachebh1 ,

Try to click "skip test connection" when you are doing your data source setting.

vyanjiangmsft_0-1683272049140.png

 

Best regards,

Community Support Team_yanjiang

rachebh1
New Member

Hi v-yanjiang-msft

I do not see the "Skip test connection" option in Power BI Desktop or the portal. Can you please provide more details?

Thanks

Bhavna

 

rachebh1_0-1684306707604.png  

rachebh1_1-1684306757597.png

 

 

v-yanjiang-msft
Community Support

Hi @rachebh1 ,

In Settings>Manage connections and gateways

vyanjiangmsft_0-1684307498411.png

Select the data connection and click Settings.

vyanjiangmsft_1-1684307571857.png

Under Authentication, there is an option "Skip test connection".

vyanjiangmsft_3-1684307742541.png

Best regards,

Community Support Team_yanjiang

 

rachebh1
New Member

Since i am connecting using a Key, there is no option to Test the connection. The same key works fine in Desktop but not in the portal.

rachebh1_0-1684311396644.png

 

rachebh1_1-1684311516587.png