Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

ISSUE: Power BI Report Builder failing to connect to an ODBC Data Source

Power BI Report Builder is not able to connect to Snowflake via an ODBC Connection when using the Power BI Service. However, It is able to connect to the database in the following cases:

  • From the Desktop app.
  • If using a dataset already published to PowerBI
  • If using an on premise gateway with the ODBC connection. 

 

On the "Show Lineage" page, the Data Source just shows unable to connect without any additional error info. 

sanketservian_0-1684215095787.png

 

Upon opening the report, it just shows an error saying Unable to render the report. Screenshot attached below.

sanketservian_1-1684215324187.png

 

Status: Investigating

Hi @sanket-servian ,

 

This specific error message is associated with not setting the correct Gateway setting in the report's settings page. If set correctly, the report will either render or provide another error message if failing to render.

 

Best regards.
Community Support Team_Caitlyn

 

Comments
v-xiaoyan-msft
Community Support
Status changed to: Investigating

Hi @sanket-servian ,

 

This specific error message is associated with not setting the correct Gateway setting in the report's settings page. If set correctly, the report will either render or provide another error message if failing to render.

 

Best regards.
Community Support Team_Caitlyn

 

sanket-servian
New Member

Hi @v-xiaoyan-msft , 
Thanks for the response. I am able to connect to the database by configuring an On Premise gateway. However, I would prefer for the paginated reports to access the database without the need of an On Premise gateway similar to how it works for the regular PBI reports. 

 

Also looking at the gateway permissions for this paginated report, looks like I can't disable the "use on premise gateway" flag. 

 

sanketservian_0-1684292921327.png

 

 

Regards, 
Sanket.