Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Grow your Fabric skills and prepare for the DP-600 certification exam by completing the latest Microsoft Fabric challenge.

Hidden reports in app doesn't work

After yesterdays update to Power BI Service app publishing I've had to rebuild my entire navigation menu. That is OK, but all dashboards that are based on hidden reports now doesn't work.

 

Workaround is unhiding the underlying reports, but I don't want the reports in the navigation panel, it just get messy. Please fix so drilling down from dashboards to a hidden report work again.

Status: Investigating

Hi @Gauteweb 

I created a dashboard based on my report , then hide my report in app ,but I can see the dashboard in app normally . Maybe you can clear your broswer cache and update again .

Recording 2022-09-02 at 13.57.35.gif

Best Regards,
Community Support Team _ Ailsa Tao

Comments
GonzaloB
Helper I

Hey @dave64164624 try unpublishing, deleting and recreating the app, it worked for me.

I know it is tedious 

darrenhandler
New Member

This is a big issue with subreports used in paginated reports, not just for dashboards.  Up until recently, I could keep those reports "invisible" in the app, and they would still operate properly when called from the main report.  Now, unless they are also "visible", the main report will show an error message about the subreport not being found.

 

Updating the app with them visible, then hiding and re-updating with them hidden does not work.

 

This needs to be corrected.  The subreports cannot remain visible and accessible otherwise they potentially  allow the users to expose data in an inappropriate way that the main report would normally control.

 

Put the non-visible feature back, please!

RahulYadav
Resolver II

Hellow Team,

It is not feasible to show all the Paginated reports in the Navigation Pane of the App with the New App Experience. We need the feature back to hide the item from the menu but still give the access of that menu item to user.

 

Thanks,
Rahul

AW97
Regular Visitor

Hi,

 

Same problem here. Unpublishing, deleting and recreating the app doesn't work for me. Unhide my reports, deploy the app, hide the reports and deploy it again doesn't work either, and honnestly this solution is not a solution. As soon as you refresh the page, the data is no longer visible again.

 

My reports are used in several applications and it is with filters that I choose what is displayed or not. I can't afford to let the users view the reports in apps and access filters. In the applications settings when hiding a report, it is only a question of "hiding" and not restricting permissions. It clearly doesn't make sense that hiding a report is impacting data access through the app.

 

We need this feature back asap, please do something...

 

Thanks, Alexandre.

AW97
Regular Visitor

Hi @v-yetao1-msft ,

 

Any news about this ?

 

I think that if it works correctly on the video you posted, it's because you're working in your own workspace as the owner. I personally work with 18 workspaces and even being admin of these workspaces, when I hide the reports, I don't see the data.

 

This is a big problem since, first, it doesn't allow me to upgrade my applications and then, the applications on which I have already upgraded, have now been unusable for almost 2 months....

 

Thank you in advance for your answer.

 

Best regards.

GClubine
Regular Visitor

Hello

I have the same problem - many paginated reports that are only accessed as drilldowns and that we do not want to show on the navigation menu. Oddly, some users are unable to access any of these reports, while others still can. All users are able to access reports on the nav menu for the app however. 

Anonymous
Not applicable

I too am having this issue. Is there any idea on fixing it. What I had to do as a terrible work around, is on my external drill through report, is create one visible sheet that is labeled About, and I hid all of the other drill through pages. 

Then make the PBIX visible, which unfortunately makes it visible, but only shows the about page.

 

the drill through hidden tabs still show up

 

I am trying to get my company to buy into the product, but having things randomly stop working like this is crazy that there is no way to undo this

daveg01
Regular Visitor

Is there an open ticket where Microsoft has acknowledged this problem?  

kbjornwall
Regular Visitor

We have the same problem and haven't managed to make it work again inspite of having tried numerous variations of everything suggested above - hiding/unhiding the reports that hold the visuals of the dashboards in the apps etc. The problem only appears within the app - outside the app the dashboard shows the tile content fine. Like some of the previous users, we're working with multiple workspaces that we are all admin of, this doesn't solve the issue though. Please help finding a fix to this. Is there an official bug with Microsoft reported? Do you know @v-yetao1-msft ?

Kind regards,

Karin

kbjornwall
Regular Visitor

Adding a link in the tile in the dashboard to anywhere (external or internal both did it) (advising the tile where to route you if you click the tile) before republishing the app (still with the tile report hidden in the app) strangely solved this issue for me.