Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Gateway disabled



I wondr if there is someone facing the same problem as me. 

My  Enterprise Gateway was working smoothly until yesterday.  I don't know how but i cannot choose my EG to refresh my dataset : 


I created a sample report to test the datasources, in the example below the error (EG disabled) is happening when i use a merge join in my power query : 



when i deploy the report with this step i have this error "You don't have any gateway installed or configured for the data sources in this dataset. Please install a new personal gateway or configure the data source for an existing data gateway" 


but deploying without the merge join, everything works fine => i can select the EG! 


I use Two souces in my report : 

SQLSEVER for RLS table 

Excle file for Fichier table 


It seems strange to have this issue after a join operation in the model. 


Thank you in advance for your help. 


Best Regards, 


Status: Accepted
Frequent Visitor

As I couldn't wait for a fix (I agree with both of you, this is an old issue which as been accepted so I don't understand why this is taking so long...) I tried the workaround and it is not as difficult as I first understood.

You have to configure the gateway separetly only for the data sources which are combined.

For example if you combine a directory "D" whith a file "F" you have to configure one data source for the folder "D" (no need to configure for each file) and one data source for the file "F".

Helper II

I agree the workaround is relatively easy for an individual or small business, but it's not feasible for a corporation.

Frequent Visitor

Any update on this?


This is becoming an old issue for what used to be a key feature.

I previously asked about this two weeks ago with no response.  What's going on?


This was a key feature we were using for at least one year.


Hi All, 


This issue has been fixed. I have verified it. Could you please try it again and give some feedback?

There is a new release of Gateway. Please upgrade it first for better performance, which has nothing to do with this issue.


Best Regards,


Frequent Visitor

Hello Dale,

I just update the gateway to the latest version (14.16.6524.1) to verify and I can confirm that this is still not working.