Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Error when trying to set up refresh schedule: Failed to load data sources. Please try again later.

Hello,

 

After publishing a report, I try to set up a refresh schedule, and I receive the error below:

 

"Failed to load data sources. Please try again later."

 

I am using an on-premises gateway (personal mode).

 

Here are the error details:

 

Activity ID: fbaa47fb-bed3-497f-9c5f-629630eede0d
Request ID: 71d6f731-dd38-fe2d-a671-354ffcd184a5
Correlation ID: 4697d43e-0e08-aff6-d80d-3045ed369aaa
Status code: 500
Time: Mon Aug 01 2022 09:00:57 GMT-0400 (Eastern Daylight Time)
Service version: 13.0.18756.45
Client version: 2207.4.12439-train
Cluster URI: https://wabi-us-east-a-primary-redirect.analysis.windows.net/

Status: Delivered

This issue has been fixed

Comments
JMSGRE
Regular Visitor

I also started experiencing the same issue, with the same status code, service version and client verion. The probolem started this morning with a dataset thaat had been refreshing for some days without changes.

antonbogomolov
Regular Visitor

The same problem 😞

AlexZERO
New Member

The same problem 😑 Does not work where there is a python or a direct request to the API 🤔

cs413y
Regular Visitor

Same problem here and it's been like that the past two days. I searched for the error in the community thread and no one seem to have a solution. There was an old post and the error just went away on it's own. I tried republishing my report as well and it doesn't work. My gateway is running with no issue.

JeffManley
Frequent Visitor

I'm receiving the same error:

 

Activity ID: 7c333353-1bc4-4dda-80f2-c51b12bf21d2
Request ID: 6b52828c-2cab-5e8a-ce8b-8ada2b5689c3
Correlation ID: 622adec5-f2f8-4bf6-30a2-ffea8b5c4108
Status code: 500
Time: Mon Aug 01 2022 21:10:07 GMT+0300 (Eastern European Summer Time)
Service version: 13.0.18756.45
Client version: 2207.4.12439-train
Cluster URI: https://wabi-us-central-a-primary-redirect.analysis.windows.net/

jisuk_kate
Advocate I

I have the same problems. All connective was okay for several month. sucessfully ran.

But starting from yesteday. Power BI report including Rscript & API doesn't work

 

jisuk_kate_0-1659389305925.png

 

neverton_76
New Member

Same problem here. Narrowed the problem down to on prem personal gateway running python.
My dataset is falling over with the following error:

Unable to detect a gateway. Please verify the gateway is up and running and try again.

  • Activity ID9f302038-e4fa-4c31-8c95-b34ea16b7aa2
  • Request IDffb6fe0b-3efa-21f8-49f9-3adc48355212
  • Correlation ID6e1bd83d-0909-dd71-a034-e728bc28bca5
  • Status code500
  • TimeTue Aug 02 2022 00:39:45 GMT+0100 (British Summer Time)
  • Service version13.0.18756.45
  • Client version2207.4.12439-train
  • Cluster URIhttps://wabi-uk-south-redirect.analysis.windows.net/

gateway is running fine and nothing has changed and refreshes were running fine until today

rlavter
Regular Visitor

Hi, I have the same error when I want to try to set up refresh schedule for more of 30 DataSet. They was running every day during last 6 months until yesterday:

 

"Failed to load data sources. Please try again later."

 

Activity ID74dbeaa6-0413-4d89-953f-26921ce2364d

  • Request ID87f267ba-51fd-69ad-3ae6-9e636f00e354
  • Correlation ID37228baf-9ca9-6be6-d0d9-7b968b7504cb
  • Status code500
  • TimeMon Aug 01 2022 19:12:16 GMT-0500 (Peru Standard Time)
  • Service version13.0.18756.45
  • Client version2207.4.12439-train
  • Cluster URIhttps://wabi-paas-1-scus-redirect.analysis.windows.net/

 

When I want to do a refresh manual I got the following error. I have verified that Gateway Personal is working fine but Power Bi Services doesn´t detect that gateway. I have installed the Gateway in another server but the problem continue affecting to more of 30 reports schedulled to run every day:

 

Unable to detect a gateway. Please verify the gateway is up and running and try again.

Activity ID: 74dbeaa6-0413-4d89-953f-26921ce2364d
Request ID: 12843af3-b297-39c7-dd3f-a4b24627bf5d
Correlation ID: 3462ccb0-c199-2155-c8fb-3eb21b0f72a6
Status code: 500
Time: Mon Aug 01 2022 19:05:02 GMT-0500 (Peru Standard Time)
Service version: 13.0.18756.45
Client version: 2207.4.12439-train
Cluster URI: https://wabi-paas-1-scus-redirect.analysis.windows.net/

 

You can see logs in the following link: 

https://drive.google.com/drive/folders/1bPsp4h-aR2afIpWo0qYcNtriCxib9Eef?usp=sharing

atm18
Regular Visitor

Seeing the same issue after updating my Personal Gateway.

Excel files seem to work perfectly fine. An issue occurs when attempting to refresh R scripts using the Personal Gateway. Have tried uninstalling and reinstalling the gateway, but the issue still persists.

jisuk_kate
Advocate I

I also uninstall and reinstall Power BI & gateway , but it doesn't work etiehr.