Showing results for 
Search instead for 
Did you mean: 

Embedded Capacity fails to resume (gen2)

Over the past several days (04/19 - 04/21), we have experianced issues resuming several of our gen2 embedded capacities. 


This morning (04/21), we had 4+ capacities fail to start.  


Reviewing activity logs, we see the following error:

"statusMessage": "{\"status\":\"Failed\",\"error\":{\"code\":\"ResourceOperationFailure\",\"message\":\"The resource operation completed with terminal provisioning state 'Failed'.\",\"details\":[{\"code\":\"InternalError\",\"message\":\"Resuming server timed out originally. The service is updated during garbage collector cleanup.\"}]}}",


We tried moving the capacity to a new resource group and then tried resuming, this didn't work.  The capacity will attempt to resume for several minutes (5 - 10) and then fails.


Example from this morning: 



I have been unable to locate any help documentation or support articles to help us get past this issue. 

Status: New
Community Support



The issue is with the memory try to increase the size of the capacity if possible and to understand more on error have a look at the below documents


When a garbage collection is triggered, the garbage collector reclaims the memory that's occupied by dead objects. The reclaiming process compacts live objects so that they are moved together, and the dead space is removed, thereby making the heap smaller. This ensures that objects that are allocated together stay together on the managed heap to preserve their locality.




Regular Visitor



Thank you for your response and the links to documentation. 


I should have noted in my original post that after the first several failed attempts to resume the capacities, we did attempt to resize them. This action immidatly failed. 


I've reviewed as much of the Gen2 documentation that I've been able to find and was under the impression that memory was dynamically allocated, unlike the Gen1 where there was a hard limit. That said, if this isn't the case, I'm unsure how we're able to manage it on Gen2. 


The last thing I'll mention is that the failed capacities finally resumed later in the morning after many attempts to start them.