Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Dataflow Refresh - Internal Error


Since last friday i'm with some issues in refresh my datasets. Most of the the refreshes that we try returns an internal error:



Error: Internal error Request ID: ad8067f3-103b-4cde-a815-9869e2a3f98c Activity ID: 00000000-0000-0000-0000-000000000000




My dataflows are connected to Google BigQuery, with Powerbi Connector,  and this never happened in the past. 
the error always happens at different refresh times, different entities,  and happens on all the Dataflows we have on the server on the various PRO accounts.
Do you have any idea of what is happening for this error


Status: New
Not applicable

I've been told the fix has gone in, however I now can't seem to load or edit dataflows without it taking inordinate amounts of time.  Far longer than before.  I've just waited 3.5 minutes for it to load a small table (around 200 records) from Dataverse.  I'm having the same problem with SQL on preminses across a gateway.  So refreshing is fixed but updating and editing dataflows is very difficult.

Advocate IV

And yet again, they are broken.

Problem was fixed on friday though.

Helper II

Still broken

Regular Visitor

Yeah, still getting the same "Error: User is not authorized to access the gateway" this morning


Hi folks - thank you for reporting and apologize for the issues you are running into.  The engineering team is actively engaged and fixing these issues right now. The issues are limited to the NCUS region. 

Helper I

I have the same problem on multiple datasource




Cluster URI:
Activity ID: 849d2ab5-40bf-4f77-8439-aa07e41fd0ed
Request ID: 27b0c794-0d35-cb84-7b00-3287db7ae235
Time: 2021-05-17 17:14:44Z


Please help

New Member

We are getting error on dataflow refresh as well since last Friday.  Even very simple dataflow will fail, data source range from on-premise database to Salesforce with same error: Can't convert 9 to proper M credential Type. Please fix this as soon as possible, this is production environment!! @MaheshPrakriya @Microsoft Power BI Development team

Frequent Visitor

it's just an illusion ...



this morning already broken ... 



Kudo Kingpin

Just to update - this was sent to me today.
I've checked and today my refresh has been running smoothly....



Hello Michael

On behalf of Microsoft, I would request you to please accept my sincere apologies for the inconvenience caused due to service interruption.

This was an issue on Microsoft BI side. We were able to correlate the issue to a recent change that occurred on the side of the service. Once identified our team worked to mitigate impact to our customers and augmented testing to avoid similar cases in the future. We are glad to know it is resolved now and working as expected. 

Can you please refresh the dataflow and let me know if the issue still persists.
At this time, We do not have a customer facing RCA, but we would make sure to drop you an email as and when it is available to share.

If you see any issues with Power BI again you can always reach out to me or my team with your request and we will try to address it on priority.

We appreciate the chance to work with you to resolve the situation, and remain available if you have any further questions or concerns.

Thank you again for contacting Microsoft Technical support.
Frequent Visitor

"Internal Error" is still occuring randomly during Dataflows refresh. In addition to that since monday I noticed that sometimes refresh takes way longer than usual and even cancelling refresh takes 30+ minutes.