Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

0

Dataflow Connector in the Service is not working

When I try to set up a dataflow in the service which pulls data from another dataflow I get the following error message:


Access token has expired, resubmit with a new access token

Details
Error = error "Microsoft.Mashup.Engine1.Runtime.ValueException: [Expression.Error] The field 'pbi.error' of the record wasn't found.#(cr)#(lf) at Microsoft.Mashup.Engine1.Language.ValueCreator.CreateValueForThrow(IThrowExpression throwExpr)#(cr)#(lf) at Microsoft.Mashup.Engine1.Language.ValueCreator.<>c__DisplayClass23_0.<CreateValueForRecord>b__0(Int32 index)#(cr)#(lf) at Microsoft.Mashup.Engine1.Runtime.RecordValue.DemandRecordValue.get_Item(Int32 index)#(cr)#(lf) at Microsoft.Data.Mashup.ProviderCommon.MashupResource.TryGetValue(Func`1 getValue, IValue& value, String& errorMessage)#(cr)#(lf)Record"
RequestId = 4be3a7a2-0702-49ba-a626-2fd91676371f
 
RomBec_0-1693322886610.png

 


I veryfied the same issue happening on two different machines.

It never occured before.

Status: Delivered

Hi  @RomBec 

I am so glad to hear that the connector works normally . I will change the status to "Delivered" .

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
v-yetao1-msft
Community Support
Status changed to: Needs Info

Hi  @RomBec 

Have you tried connecting to dataflow in Power BI Desktop? See if it reports the same error.

 

Best Regards,
Community Support Team _ Ailsa Tao

RomBec
New Member

The connector is working again as before.

v-yetao1-msft
Community Support
Status changed to: Investigating

Hi @RomBec 

Do you mean that Desktop's connetor is fine, or that your problem with Service is back to normal?

 

Best Regards,
Community Support Team _ Ailsa Tao

RomBec
New Member

The connector in the service is working again.

v-yetao1-msft
Community Support
Status changed to: Delivered

Hi  @RomBec 

I am so glad to hear that the connector works normally . I will change the status to "Delivered" .

 

Best Regards,
Community Support Team _ Ailsa Tao