Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Data refresh through PBI Gateway keep prompting credential missing incorrectly

While using PBI Service with on-premise data gateway connecting local excel files, the refresh keeps failed with "credentialMissing" error, however all credentials has already been given and verified (with a green tick next to the each data source shown under gateway connection), nothing can do......



Status: New
Regular Visitor

Even we were suggested the same workaround as mentioned by @Anonymous . We have merge and append steps in our query. So the Microsoft Engineer said that this issue might be due the these steps and using Folder as the datasource connection.

Not applicable

@sunnyleung @mlucking  @HemantNagar I can confirm my issue is now resolved,  Steps I have taken below has worked.  Please note Microsoft Engineer has not come back to me yet, but I cant wait on them and kept trying different things.  See below what has worked for me (I am not sure which step has solved but see the list of actions I have taken):


  1. Uninstall my Power BI desktop version (2.84.802.0 64-bit).
  2. Installed latest updated Power BI desktop version (2.84.861.0 64-bit).
  3. Get the old version of your Power BI desktop file when it was upload on the service and was working fine.  Lucky for me our drives store back ups twice a day so I found the last modified version which was working fine.  (This is the most important step, if you don't have the last working version file then it wont work).
  4. Make all the changes to this old version file again, add data or visual changes you wanted to make and upload the file on the service, you can replace the existing file on the service.
  5. And hit manual refresh button or if your file has scheduled refresh activated it will automatically start to refresh and it will not fail.

Let me know if you need me to explain anything in detail.  Got to go to a meeting, try it out.




Advocate I

@Anonymous thanks for your workaround steps. I believe a colleague of mine did something similar (although she was already on the latest desktop version) but she still has the issue.  Please let me know if Microsoft suggests anything different.  Thanks again and congrats on finding a solution for your issue!

Frequent Visitor

We are having the same issue with recent updates to reports that reference folder data sources.  We found that some files will fail and others are fine still accessed via the same folder data source.  I can also confirm that adding individual file data sources for the failed ones seem to work as a workaround as painful as it is.


It is good to note this seems related to a particular M sequence, but it is too late for us to revert as most people use MS Store version of PBI Desktop (simpler/secure app updates, etc).


I would also be interested to learn when a fix available so we can rollback the chaos we are creating with this workaround.

Not applicable

@ChristiaanB I am still waiting on the Microsoft Engineer to respond, but there is another issue with Power BI Service, suddenly all the data from SQL DB source with UTC time are not converting to Australian time AEST.  As much I like regular updates from Microsoft when such things happen it is a pain.  This is all happening since Monday 24/08/2020.

Helper II

I've been having this same issue.  However I noticed on the August 2020 On-Premises Data Gateway notes state that the Mashup Engine has been updated and now matches the August 2020 version of Power BI Desktop.  I went ahead and updated the Gateway to the new August 2020 version.  I then tested a couple of reports that have been failing and now they are sucessfully working. 


You can view the MS Blog post about the gateway update at


Hopefully this resolves anyone who is having this issue.

Frequent Visitor

@mattyj2009 - did you have to update & republish reports to get it working on updated gateway?  We already updated our gateway nodes to 3000.54.8, but still the folder access issue persist for us.

Helper II

@ChristiaanB - I didn't have to republish the reports.  I just updated the gateway software and did a manual refresh on the dataset in Power BI service and it started working (the scheduled refreshes also succeeded after this update).  I also looked and both of my gateway nodes show version 3000.54.8.

Frequent Visitor

@mattyj2009 - bummer!  That does not seem to work for my test report.  It references 3 files from the same folder - 2 works, 1 fail.  If I map the failing file to a file data source (not folder) using the same credentials the dataset can refresh again.  Glad it resolved your issue at least.


According to @Anonymous 's post on Wed I suspect the underlying cause is still present in some form as MS engineer suggested (26/8).

Frequent Visitor

Just wanted to report that I have also experienced the issue described here today after applying a small change into one of my reports. Same story the report that has been refreshing succesfully till this morning no longer refreshes automatically following the changes. I have other reports that uses the same files which continue to refresh. As noted looks like an update to an existing report causes this issue.