Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Data is changing when importing from SP list to Power BI report

In my SP list it shows me all the offices that I manage hardware for and what they have in inventory per item. (For example: the Austin office has 23 professional laptops, 30 docking stations, 50 webcams. They also have a pending order for 50 monitors.)It also shows me if they have pending orders for additional equipment. For some reason when I connect to my SP list from Power BI, none of the data is coming through correctly. Or I should say none of the column names come through and I'm not sure if that's why the rest of the data is not showing correctly. Where it would show me the name of the product( i.e. professional laptop, docking station, webcam, monitor) it is only showing random numbers and letters. In my SP site I have several columns but the only ones I choose to pull in are: part, part: description, location, current inventory, pending inventory, preferred inventory. When I view the table in power bi it is showing column names of: filesystemobjecttype, contenttypeid, authorid, editor, odata_uiversionstring, attachements to name a few. None of the data in those columns are what is shown in my SP list. How can I resolve this issue?

Status: Needs Info

Hi  @jaytrice26 

Are you doing this in Service or Desktop ? Is this the first time you've connected to the SP list to get data?

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
v-yetao1-msft
Community Support
Status changed to: Needs Info

Hi  @jaytrice26 

Are you doing this in Service or Desktop ? Is this the first time you've connected to the SP list to get data?

 

Best Regards,
Community Support Team _ Ailsa Tao

jaytrice26
Helper I

Hello - I am doing this in the Desktop app and this is the first time I have connected to the SP list to get data. The solution provided by @danextian resolved my issue. I was using implementation 1.0 instead of 2.0.

TStroud
New Member

I have a couple of questions to confirm.
1. are you exporting data on Service or Desktop? Or is the data exported from both places incomplete?

    Incomplete in both places
2. have you tested this feature before? If your data is less than 300 rows, is the data complete after export?

    No and No
3. what are the Service and Desktop versions you are currently testing?

    We get the issue from the published App, Desktop and Service both current version. 

 

Thanks, 

 

Troy Stroud

Troystroud@pfgc.com

jaytrice26
Helper I

@v-yetao1-msft I'm working in Power BI Desktop.

@TStroud I'm importing data from SP list into Power BI desktop. The data is exported completely and I'm using desktop Version: 2.99.621.0 64-bit (November 2021).