Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Custom visuals have been disabled for your organization

In a Power BI embedded (via azure workspace) I get the following error on some visuals:

"Custom visuals have been disabled for your organization"

The visuals are not custom visuals from the custom visual gallery but very simple standard visuals, for example a standard Card visual to display a string, referring to a measure with a simple IF statement to choose between two strings.

A common element to all the places where I see this bug is the use of IF statement in the measure that is displayed in the visual.

In all cases the visual is a simple Card.

 

Status: New
Comments
donquijote
Advocate IV

@tzvikei in my case I see some of the visuals display correctly but there are two that still error.

My visuals are not custom visuals but just a normal "Card" based on a measure that selects a string based on other measures with an IF statement.

This visual works as expected on the Power BI Desktop but still error when embedded on Power BI Service.

 

In case it helps the IF expression to calculated the measure contains OR, AND, and NOT statements:

MsgWarning = IF(OR(Table1[DateAtCount]>3,AND(Table1[DateAtCount]>2,NOT(Table1[IsOutSelected]))),"Please select only ONE date","")

 

 

Anonymous
Not applicable

@donquijote do you still have issues with visuals and the IF-statement?

donquijote
Advocate IV

@Anonymous this is still error for me. Is just a card visual with an IF statement to choose between two strings (formula in my previous comment). In this case the error message I see is a standard "Can't display de visual. See details". The error about Custom Visuals doesn't appear for me anymore.

 

Anonymous
Not applicable

@donquijot ok, we have still issues with Image Viewer visual, that we didn't when we tested last week, so I have reopened our support case for this issue. Not 100% sure if it is the same root cause though.

Do you experience differences in different browsers? Image Viewer seems to only have an issue in the latest version of Chrome.

donquijote
Advocate IV

@Anonymous my error with the card visual happens both on Chrome and Edge. I am not using the image viewer so I'm sorry I can't provide input on that one.

mtimour
New Member

Bonjour 

moi aussi je rencontre le meme problème je peux utilisé le visual Map Azure sur PBI Desktop sauf qu'au niveau du rapport APP je recois le message suivant :" les visuels Map Azure ne sont pas activé pour votre organisation"

 

Merci