Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

0

Custom Label for Data Label not working on PowerBI Service

Hello all, we are trying to show/hide the Data Label using a column with the definition below:

 

Display custom label = IF(
    MOD(financials[Month Number], 2) = 0
    , " "
)

 

 

This [Display custom label] field is being assigned to the field of Custom label in the Data Label visual of a chart.

CCLiew_0-1688552013123.png

 

I created an MRE (Minimal Reproducible Example) using the sample dataset (financials) provided by PowerBI to reproduce this issue and below is the result.

 

At the right side, it works fine on my PowerBI Desktop - Version: 2.118.828.0 64-bit (June, 2023).

However, when we publish to PowerBI Service, it is not showing the Data Label (at the left).

custom-label-not-showing.png

 

We could not provide the value for the False condition due to some constraints, but that is an optional field, the PowerBI Service should work like the one in the PowerBI Desktop.

 

This is the MRE: https://filebin.net/aoot6la1vnl4quvl

 

Any workaround or solution for this?

Thanks.

Status: Delivered

Hi @CCLiew ,

 

This fix has been rolled out to service and will be in the future version of desktop. 
As a workaround:
You may update the DAX expression so it returns the field you would like to display when the condition is false. This will address your issue. 

For example:

Display custom label = IF(
    MOD(financials[Month Number], 2) = 0

    , " "

, financials[Gross Sales]

)
 
Best regards.
Community Support Team_Caitlyn
Comments
v-xiaoyan-msft
Community Support
Status changed to: Accepted

Hi  @CCLiew ,

 

We have reported this issue and submitted it to the product team.
They have been aware of the issue and the engineers will do their best to resolve it. I will update here if there is any progress, so please be patient. 

 

Best regards.
Community Support Team_ Caitlyn

CCLiew
New Member

hi @v-xiaoyan-msft, noted, thank you.

v-xiaoyan-msft
Community Support
Status changed to: Delivered

Hi @CCLiew ,

 

This fix has been rolled out to service and will be in the future version of desktop. 
As a workaround:
You may update the DAX expression so it returns the field you would like to display when the condition is false. This will address your issue. 

For example:

Display custom label = IF(
    MOD(financials[Month Number], 2) = 0

    , " "

, financials[Gross Sales]

)
 
Best regards.
Community Support Team_Caitlyn
JasonBreedlove
Frequent Visitor

Following

R27878
Regular Visitor

Hi @v-xiaoyan-msft 
my problem is that

in 

SWITCH(TRUE(),...,...,...) combo
no else or false part...
what i do? 
My automated reports do not look good... 
 
R27878
Regular Visitor

Hi @v-xiaoyan-msft 

 

I recreated the SWITCH(TRUE(),...,...,...) form to 
IF IF IF form,  added Blank when the condition is false

but the result is the same, not display Custom label in the visual.

R27878_0-1696324580099.png

 

aandrzejewicz
New Member

Hi @v-xiaoyan-msft 

We have the same problem in Version: 2.121.903.0 64-bit (September 2023)

Afives522
Frequent Visitor

Hi,

 

Has this been resolved? I'm still encontering the issue when I use custome label, it doesn't show in the PBI Workspace. 

PBI Desktop: Version: 2.121.942.0 64-bit (September 2023)

migbenp
New Member

Power BI Service do not show custom labels yet. Please help!!!

 

Version: 2.121.903.0 64-bit (September 2023) 

 

WEB View

migbenp_0-1696473733311.png

Desktop View

migbenp_1-1696473755334.png

 

I´ve tried simpler labels as well 😞

davejl
Regular Visitor

doesnt seem to work at my end as well..appears on pbi desktop but not online..