Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Couldn't load the schema for the database model + Enter your e-mail adresse popping up since June 22

1. Since the June 22 Update the the registration dialog to enter a e-mail adresse keeps popping up every time you start PowerBi Desktop. We only use PowerBi local, no need for registration. This dialog can no longer suspressed via regkey Computer\HKEY_CURRENT_USER\SOFTWARE\Microsoft\Microsoft Power BI Desktop\ShowLeadGenDialog=0

 

2. A few clients are no longer able to start PowerBi Desktop, because the message "Couldn't load the schema for the database model" appears, doesen't matter what kind of report we try to open.

Status: Investigating
  1. Whether you have used the web download version or the Microsoft Store version of Power BI Desktop, as far as my test, it seems work fine with the web download version when I used the latest version of Power BI Desktop
  2. Whether can open a new blank report to connect to the same data source in this issue, or these reports can be opened under previous version of Power BI Desktop

 

Best Regards,
Community Support Team _ Yingjie Li

Comments
v-yingjl
Community Support
Status changed to: Investigating
  1. Whether you have used the web download version or the Microsoft Store version of Power BI Desktop, as far as my test, it seems work fine with the web download version when I used the latest version of Power BI Desktop
  2. Whether can open a new blank report to connect to the same data source in this issue, or these reports can be opened under previous version of Power BI Desktop

 

Best Regards,
Community Support Team _ Yingjie Li

vicigg
Regular Visitor

Hello

2. I have the same problem

Chris77
New Member

We are using the web download version.

 

We rolled back from PowerBi version 2.106.582.0 to 2.104.941.0 till the issues are fixed.

With 2.104.941.0 everything is fine.

KevinParijs
Frequent Visitor

I have tried quite some things:

- Reverted back to May 2022 (the Sharepoint connector was acting up in my case, so I couldn't refresh the data)

- Installed June 2022 again and disabled the infrastructure update (didn't change anything)

- Removed the WebView2 from windows (didn't change anything)

- Installed Edge (on the Windows Server 2012 VM I was working on) (didn't change anything)

- Uninstalled June 2022 64 bit version & installed the 32 bit version (also June 2022), this did the trick for me! 😮

 

Hopefully the July 2022 version will solve the current issue!

tjdatalogz
New Member

I was getting the same error:

"Couldn't load the schema for the database model"

I downloaded PowerBI from the Microsoft Store and now it works.

Super frustrating I had to spin up/down multiple different VMs to troubleshoot this. It is a pain that Microsoft Store is not on Windows Server.