Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Cannot connect to Azure SSAS model since dec 2020 update


I have lot of reports connect to Azure SSAS model, and editing with PowerBI desktop.

however since the desktop version upgrade to december 2020, I can no long open the report.

I get error says:

Unable to connect

We encounterd an error while trying to connect

details: "The given credential couldn't be refreshed"


any idea when this can be fixed or is there a way to work through?


Status: New
New Member

Same problem here, very annoying. Removing the data source settings of the AAS connection and reopening the report is a temp fix. It seems like the Azure Analysis Services connection is treated as an on-premise SSAS.

Community Support
Not applicable

The fellow on the other string gave the answer - here it is paraphrased.

Hey Team, for those of you who do NOT download / update PBI from the app store - when you upgrade to Dec 2020 you are going to hit a sign in issue if the report is hooked into an Azure cube. I couldn't find the file on my machine to delete but a nice fellow on the PBI forums gave the solution - boot a blank copy of Power BI, go to Data Source settings and clear the permissions for anything you have pointed to that Azure cube. That fixed it for me.
Resolver II

Hi All.

I'm actually experiencing the same issue. Once I installed the February Desktop update, I was unable to open any of my previous reports. Things I've tried:


1. Open a new workbook, clear all credentials. I was requested to sign back in. While having a new untitled workbook open, I was able to successfully open my report. However, when publishing, I receive the same credential issue.

2. Once credentials have been cleared, attempt to open existing workbook with Azure model does not work. Same credential refresh issue.