Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Can't see hidden fields with new field list preview feature



I have the new field list preview feature turned on and when connecting to Power BI dataset or Azure Analysis Services, I can't right click on the field list and select 'View hidden' anymore. Can this option be added back in.




Status: New
Community Support



You may add a local model to enable it.


Yes - please re-add.

Adding a local model is not always an option and when doing so removes any display folders used in the tables/fields, essentailly flattening everything.

Helper III

Yes, having access to hidden fields is crucial when building reports and debugging the content - ie. being able to add key columns or other numeric columns to check that we have the correct data before removing the fields from the report and publishing.

I typically add hidden drillthrough report pages with a lot of "hidden columns" used in table visuals while the report is under development. Makes it easier to track any errors in data or calculations.

Advocate I

much agreed we need it back this is crucial for any data analyst or PBI developer.

Adding a local model is not an option for PBI plugged on onprem AS, luckily we can disable the new field list feature to have show hiden back.



Not applicable

@v-chuncz-msft this should be marked with a bug tag, since this is clearly something missing in the new preview feature. Adding a local model isn't an option for us either

Community Support



There is already an idea, you may leave a comment and vote it up.