pdeville
Advocate I
5 years agoStatus:
New
Can't create a Data Gateway ADLS Gen2 connection on a container with a lot of data
I have an ADLS Gen2 Storage account with 2 containers:
- container-one: 1MB of data / 10 files
- container-two: 4GB of data 56 000 files
I can create a data sources on my Data Gateway on container-one (using master key)
But I can't create a data source on my Data Gateway for container-two.
Error: Unable to connect the datasource undefined -2147467259 Timeout Expired.
2 Comments
- v-chuncz-msft
Community Support
As far as I know, very large number of files in a container is not handled gracefully. A workaround is using smaller number of files in alternate container.
https://docs.microsoft.com/en-us/power-query/connectors/datalakestorage#troubleshooting
- pdeville
Advocate I