Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

0

Bug with date being datehour without a reason

Hi,

I've come up with power bi recently but i already found i bug, here it is:

 

When you create a data using existing sharepoint excel and gettting the date of it, when you import it and use it it's alright, all works together perfectly, but here i found a specification.

rhayezsncf_0-1717481152802.png

Here is a column with datein shortdate format from an array in excel, when i import it it works great:

rhayezsncf_1-1717481253461.png

rhayezsncf_2-1717481330662.png

 

however for some reaon, when i add another data in the X axis and place it below the DATE, here's what happen to my histogram: 

rhayezsncf_3-1717481407763.png

i've checked all around, the DATE is still in Date not DateHour or anything, idk if it's a popular bug but in case no one already report it, here it is

 

I'm here for any questions !

 

 

Status: Delivered

Hi @rhayezsncf 

I am so glad that you have fixed this issue. I will change the status to "Delivered " .

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
v-yetao1-msft
Community Support
Status changed to: Investigating

Hi @rhayezsncf 

Thanks for your feedback ! I have some questions need to confirm.

1. If your excel is not on SharePoint but locally, does the same problem occur when you do the same operation ?

2. In which visual does this happen? When you add the Date column in, the time displayed is the normal day, but then you add other columns and the time display changes to hour, right? And what type of column did you add? Would the same problem occur with other columns?

3. What version of Desktop are you currently using?

 

Best Regards,
Community Support Team _ Ailsa Tao

rhayezsncf
Regular Visitor

Hi @v-yetao1-msft, thanks for your time!

I've tried it locally but doesnt change anything, here's my 2 histogram that are concerned 

Capture d'écran 2024-06-05 082941.png

 DATE is still messing somewhere, i attach back the parameters of my DATE column, maybe i've done something which will always return datehour

Capture d'écran 2024-06-05 083555.png

in both histogram, there isnt any other X axis data except DATE.

In my case, that error occur on all of my grouped histogram.

Here's my version: 2.128.1380.0 64-bit (avril 2024)

 

rhayezsncf
Regular Visitor

Ok, so i found why.

I dunno why that option is implemented but here it is : 

rhayezsncf_0-1717746203351.png

in your X Axis you have to put it to "Category" so that i takes YOUR filter.

that's all folks!

v-yetao1-msft
Community Support
Status changed to: Delivered

Hi @rhayezsncf 

I am so glad that you have fixed this issue. I will change the status to "Delivered " .

 

Best Regards,
Community Support Team _ Ailsa Tao