Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Bug: "Building your app..." spinner when launching apps from app link

Hello, for some reason over the weekend, the link for our app no longer loads.  All our users are getting stuck with a "Building your app...." spinner and the dashboard never loads.  It was working fine a few days ago.  


Users can access the app fine if they load it from   They can not access form the direct app link...



I see some posts like this from a long time ago.  Please help, we need these app links to work - it is how users access their information!



Status: New
Community Support

@kurtsmetana ,


I'm afraid I could not reproduce your issue on my side. Service version13.0.13456.212 and my tenant is East US 2 (Virginia). I would suggest you submit a support ticket here for further analysis.

Support Ticket.gif 


Jimmy Tao

Advocate III

@kurtsmetana Same is happening for us too.  When we click on update app and then when the option comes up for go to app, we get the "Building your app..." message.  If I open a new tab and go to the apps section and click on respective app, it will open.  But there is defintiely a problem.

Resolver I

I am recieving this error as well as of Wednesday

Frequent Visitor

Hello after messing around with the app, I learned the issue is the "New Navigation Builder" option.  When turned on the link works fine.  When turned off the link does not work.



Frequent Visitor

Thanks @kurtsmetana ,I had the same issue when using the link that is created when Updating the App. After turning on the New Navi Button there was no more Builing your app... message.

Advocate III

@kurtsmetana Thanks for your workaround.  But, we don't like the look of the "New Navigation Builder" so we purposely leave it disabled.  They still need to fix the issue because there are users that prefer not to use that feature.

Regular Visitor

We have the same problem - and happened in the July 2020 release.  Did some troubleshooting and it only seems to occur if the app has Excel in it.  Way to work around is to refresh or use backpage twice.  Not sure why this would happen.  Will raise a call.

Not applicable

Has this bug been fixed? I have a gateway behind the firewall and have enabled the "New Navigation Builder" setting on my app but it was already active during the initial build. Not sure what to do other than direct users through the portal to access the report. The app link is the problem. Please advise. Thanks.

Frequent Visitor

I had this issue a few days ago. It was happening only to me (Admin) while my users were not having any issues. I solved the issue by upgrading the workspace where the app was built.

Not applicable

I confirm.
Workspace upgrade solved this problem.