Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Bug in March 2018 PBIRS Releas: Export Data not working

After updating to the March 2018 release of Power BI Report Server, the Export Data function is no longer working.  The link is visable to show Export Data, but once clicked nothing happens.


Chrome Console shows the following error:- ' Script error for "odataFilterParser" '.

Status: New
Advocate II

Team, I see quite some users are happy with the Export data option working at the moment. We are rolling out new Version 1.2.6660.39920 of the  Power bi report server with the fixes provided in the week end. Will update to all once it is successful from my side too. Thank Power BI team for listening and supporting to our queries and addressing it on time. Truely appreciated for your team work. 

Not applicable

@RavinderSunkara Please be aware that the "March Version" also broke some functionality related to  SSRS/Paginated Reports ("Lookup" functions, see also

I haven't received a confirmation from MS yet that this bug/issue is also fixed in the latest patch.

FYI: a rollback to previous "October 2017" isn't a simple process of uninstalling the "March 2018 Version" and installing the "October 2017 Version" again. It seemed that the "Reportserver" database was also touched by the "March 2017 Version" so we had to restore the "Reportserver" database as well.


Frequent Visitor

 Note that in latest versiion of PBIRS March 2018, Export data to csv does not work at all from the web portal. It only work from the desktop application optimized for PBIRS March 2018, but fails once the file is successfuly uploaded to the web portal. Please check and update on a fix. If anyone else noticed the same bug then please report it here.

Frequent Visitor

There are more problems with bookmark links when linking to images. The link does norcwork.

Regular Visitor



I can't get the Export to Excel to work and i'm on Version 1.2.6660.39920 (March 2018).


Is there anything that I do wrongly ?


This is important as our user need to export the data and work on it

Not applicable

I also can't get the Export Data to Excel (or CSV, for that matter) to work and i'm on Version 1.2.6660.39920 (March 2018).


This is important as our users need to export their data.


Is there any ETA on a fix for this?

Not applicable

I usually dont double post, but this is a critical issue. When we tried reverting to October release in DEV, the upgrade was very destructive - we had to reinitialize the database, which meant restoring folders, branding, security, schedules, etc.


I am not keen on reverting my TEST and PROD environments and doing the same thing there.


So that I can define for my users what they are looking at - is there a general guideline for a fix? Days, Weeks, Months? So that I can plan my environments accordingly.



Not applicable

I do have the same issue. I have just installed version of the server, but the export ist not working. The Power BI dashboard I am testing uses a table visual. But it also does not work with a matrix visual. I have tested with a Direct Connection to a Tabular Model as well as a dataset from a csv-file (20 rows). I have also restarted the Power BI Server as well as the whole machine. And I have cleared the caches of both browsers I am testing with (IE 11 and Firefix 59.0.2).


Help is greatly appreciated 🙂


Kind regards


Resolver II

I've just downloaded and installed the latest RS (1.2.6660.39920) and Desktop (2.56.5023.1043), as you can see:





Despite this, the "Data Export" still doesn't work on the Report Server. I click on it, but nothing happens. No errors, no pop-up, nothing.

Resolver II

UPDATE: It's working now though I did/changed nothing at all on my side (or at least nothing I can think of)...