Showing results for 
Search instead for 
Did you mean: 

Fabric is Generally Available. Browse Fabric Presentations. Work towards your Fabric certification with the Cloud Skills Challenge.

BUG: "Formatting options are unavailable for this visual"

In Power BI Desktop I am running into an issue where I cannot format visualizations that are part of a group. When selecting the visualization in the group and navigating to the Format visual tab, no options are available and it says "Formatting options are unavailable for this visual". The only workaround is to ungroup the visualization, make formating changes, then re-group it with the other visualizations. This has been happening for the past week or two. Sometimes it will let me format visualizations in a group, but most of the time it shows the message below. 

Screenshot 2023-04-20 142404.png

Status: Investigating

Hi @jaykayelsemicol ,

I tried again and still can't reproduce the problem, also haven't found ICM reported internally. If the problem persists, I suggest you create a support ticket, it's free for pro user and a dedicated engineer will come to dig the problem for you.


Best regards,

Community Support Team_yanjiang

Frequent Visitor

I'm having the same issue. I was already wondering if it was only happening to me or if others also experienced this issue. It happens indeed when you've grouped a few visuals. In my report I use bookmarks to choose which chart should be displayed. 
I also noticed that when this issue occurs, and you get the functionality back by switching pages or some of the other tricks mentioned earlier, not all the changes you make will be saved. After saving and closing the file, charts which I had moved were back in their original positions and sizes, and color changes were not saved as well. 
For example, the one now displayed as burgundy, was dark blue in PowerBI desktop when I published the report...



Frequent Visitor

Yes, this is truly annoying. It is one thing to lack new functionality but this is a quite heavily used and somewhat basic function that is almost impossible to fix if your report has many selections, bookmarks, and buttons on one page.

Regular Visitor

Also experiencing it:


Notice: the reports are not grouped.
I'm using the "blue" Power BI (Microsoft Store's), Version 2.118.621.0 64-bit (June 2023).


Advocate I

I have the same problem. if i duplicate the viz then formatting option avialble for both. when one was deleted, no formatting option available. June 2023 version.

Frequent Visitor

pbi error.jpg

Also have this issue
Version: 2.118.621.0 64-bit (June 2023)

It's happening with buttons and shapes within groups. I set up all of my bookmark layers and finalize by attaching the bookmarks to button actions, then test to ensure they are displaying proper (tend to build multi-tiered submenu bookmarks.

Each time try to edit the button within the group I get the "Formatting Options are unavailable for this visual". If I move the button outside of the group it's iffy if I get it. If I create a new button, set the action, and then move it into the group it works as expected, which works but not with my workflow.

Frequent Visitor

I had this issue as well but it was happening on a single visual. I was able to just hide the visual in the selection pane, then unhide it, and the formatting options were then available. 

Frequent Visitor

This is to say the least... ANNOYING .... Sometimes if I click save, the options show, if I close the file and go back in it works once or twice... I completely uninstalled PBI Desktop... installed again and nope still the same as of 7/13/2023. 

My work performance is dragging due to this.... Help us Microsoft!

Windows x64 machine, 16GB Ram, etc. 

Advocate II

Same here. It seems to be random, and it might just be my imagination, but I've noticed it more often with copied objects. (I have renamed them.)

Will make a video next time it happens and share.

Using latest version from Store.

Regular Visitor

Happened today to me on "shape map". I was not using any grouping at all!  I don't know if it's really related but when I changed the name of the 2 maps in the "selection" pane, it happened. I only could have solved by duplicating the maps but it's quite annoying and definetly a bug.

Version: 2.119.666.0 64-bit (July 2023)

Frequent Visitor

Same problem... hiding and unhiding as @JulianPBI suggested works temporarily.