Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Apply button is greyed out when adding a data source to the on-premise data gateway

I noticed when I published a report with an on-premise data source (SAP BW) along with cloud data sources (Sharepoint), the Apply button is greyed out in the gateway connection settings:



Again, this is only applicable to newly published datasets.

For the existing ones, there are no errors, and I can refresh successfully. Like this one, it has actually the same setup, just published in a different workspace some time ago:


I just experienced this yesterday. 

Any of you are experiencing it now?

Appreciate the responses!



Check out the comments for the workaround


Microsoft has also posted the issue on the Power BI Support page. Expect the fix to be on 24th of January



Status: Accepted

Hi @Anonymous ,


This is acknowledged as an issue. We have reported the issue and submitted it to the internal icm platform, No:360537118 . Engineers will do their best to resolve the issue. I will update you here if there is any progress , please be patient.



Best regards.
Community Support Team_ Caitlyn


Regular Visitor

Same issue here.  Is there an eta on when issue will be resolved.

Not applicable

@ntdanh Nice to know the workaround works to you as well! 

Advocate III

@Anonymous Wow, can't believe that work-around worked, thanks!

Regular Visitor


We have the same issue. I hope it will be solved soon. 

Thanks in advance!


p.s. @benz_te thank you for the workaround!

Regular Visitor

Hello @v-xiaoyan-msft,

same issue here.


@Anonymous many thanks for the workaround. It works for me as well.



Frequent Visitor

I've got a second workaround...


1. Publish a new pbix file with the same name as the original to the workspace, and ensure that you have imported at least 1 table from each data source, however DO NOT include one from Sharepoint.


2. Map your data sources.


3. Replace again with the old pbix file...


this has worked for us here, where the mapping has stayed.

Regular Visitor

There is also something wrong with Sharepoint Folder connector in Power BI Desktop. All reports using this connector in PBI platform is showing as Sharepoint List connector and it's not necognized as source in settings. BI Team please look at this also.




Frequent Visitor

thanks @gazsam2 

your workaround works fine for us (and easier than to go to dev tool in the browser)


hope this issie will be fixed asap by Microsoft

Not applicable

@gazsam2 Good to know there's another workaround! More options the better

Microsoft has now posted the issue in the Power BI Support page: (just checked 20th of Jan, 2023 UTC)



New Member

Having the same problem
microsoft ticket.JPG