Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Accountkey limited to 200 characters in the new interface of the Data Gateway

This week the new interface for the Data Gateway is introduced.

 

When adding a new data source with Key verification, we get an error that the accountkey is limited to 200 characters. Previously this limit was not there. Is this a bug in the new interface?

 

2022-05-12_11-52-41.png

Status: Delivered

Hi @Arie 

I see you have got the solution. By going back to the old interface, there is no limit to the number of characters in the character. I will update the status of the issue to "Delivered" so that users with the same question can find the answer.

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
Arie
Advocate IV

I got a response from Microsoft that this is listed as an issue.

 

With the query parameter ?newManageGatewaysUI=false you can go back to the old interface where the 200 character limit doesn't exist.

thomasbibin
Regular Visitor

It's a bug. MS is on it

v-yetao1-msft
Community Support
Status changed to: Investigating

Hi @Arie 

So the current solution is to go back to the old interface ? So does Microsoft say when this issue will be resolved ? If there is any news, can you come back and let everyone know ?

 

Best Regards,
Community Support Team _ Ailsa Tao

Kraggle
Frequent Visitor

We are also affected by this - I almost thought I'm crazy beacuse I was pretty sure it worked during our evaluation phase 😁 

 

Thanks @Arie for sharing the workaround - important to note is:

 

 

 

The workaround does work:

Go to Dataset > Settings > Gateway connection > Select Drop-Down "Manually add to Gateways"  from "Maps To:" 

Then a new DataSource will be added to the Gateways and you can add the Service Account with it's key file without being blocked by a 200 Character Limit.

 

*edit*

Going to "Manage Gateways" and adding the URL Parameter ?newManageGatewaysUI=false  WILL NOT JUST WORK, because there is no "Add new DataSource"-Button 

 

There is a Add new DataSource Button, above "Gateways Clusters"

v-yetao1-msft
Community Support
Status changed to: Delivered

Hi @Arie 

I see you have got the solution. By going back to the old interface, there is no limit to the number of characters in the character. I will update the status of the issue to "Delivered" so that users with the same question can find the answer.

 

Best Regards,
Community Support Team _ Ailsa Tao

Kraggle
Frequent Visitor

Hey @v-yetao1-msft 

when I remember the last time correctly, it is also fixed in the new interface - workaround shouldn't be necessary anymore

Arie
Advocate IV

It is also fixed in the new interface now, so the workaround is no longer necessary any more.