Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
009co
Helper IV
Helper IV

Create new KQL database - stuck on loading indefinitely after being created

I am going through one of the Fabric real time analytics tutorials https://learn.microsoft.com/en-us/fabric/real-time-analytics/tutorial-1-resources

 

I am having problems with the create new KQL database step. After entering the new KQL database name, and clicking Create button, the page doesn't show the database details page instead it shows "loading" indefinitely. I have tried this several times with existing and new Workspaces with no success. It seems like the KQL database creation process has issues.

 

When I try to navigate way from the loading page by clicking Home button it takes a few seconds. When I navigate back to the Workspace where i created the new KQL database, i can see the new KQL database item. However if I try to open it then I get back into the "loading" indefinitely situation.

 

This prevents me from seeing the new KQL database details page and enabling OneLake availability per the tutorial. I am not able to use the new KQL database for the purposes of the tutorial.

 

Any ideas on what is happening here?

 

I am on the Fabric trial btw.

 

 

1 ACCEPTED SOLUTION

@009co Can you try creating the DB with a different name instead of NycTaxiDB also remove &clientSideAuth=0

 

Regards

Geetha

 

View solution in original post

6 REPLIES 6
GeethaT-MSFT
Community Support
Community Support

Hello @009co Thanks for posting your question in Microsoft Fabric Community

I hope you have followed the steps provided in the document, I tried to repr from the document and was able to create a database, can you share some screenshot of the error to better assist you, or it could be an intermittent issue if you can close and reopen the lakehouse and give it one more try.

Here are the steps I have followed 

GeethaTMSFT_0-1687301003230.png

Toggle the button to Active and select Done

GeethaTMSFT_1-1687301059721.png

Database with NycTaxiDB is created

GeethaTMSFT_2-1687301082149.png

 

Regards

Geetha

 

Thanks for reply GeethaT

 

Yes that is what I am doing. Here are screenshots:

 

Create new KQL Database

 

kql 1.png

kql 2.png

 

However instead of showing the detail page for the new KQL Database it gets stuck indefinitely on the Loading page.

 

kql 3.png

 

If I try to go back to the Workspace and try to open the new KQL Database 

 

kql 4.png

 

 

it gets stuck indefinitely on the Loading page.

kql 5.png

 

I have not yet been able to create a KQL Database successfully in many many attempts.  It always gets stuck on the loading page and never goes past it.

 

Something in my Fabric instance seems to be off.

@009co Can you share the URL of the loading page?

Regards

Geetha

I just tried creating new KQL Database as above and it gets stuck on loading. That page's url:

 

https://app.powerbi.com/groups/0817e2db-1f14-458e-9f73-aafb5fea21d1/databases/9b950f27-6e36-4b13-81e...

 

Thanks!

 

Edited to add: 

 

I have another unresolved unrelated issue (see thread link below) where a very simple Dataflow Gen2 query also runs indefinitely / times out. Maybe related to this KQL Database issue? Possibly my Fabric instance is under resourced or otherwise degraded?

 

https://community.fabric.microsoft.com/t5/Dataflows/Dataflow-Gen-2-dataflow-queries-with-PIVOT-long-...

 

@009co Can you try creating the DB with a different name instead of NycTaxiDB also remove &clientSideAuth=0

 

Regards

Geetha

 

Simply removing &clientSideAuth=0 from the url string allowed the url to be resolved!

 

I was then able to activate the database.

 

Even after activating the database, if I try using the full url that includes &clientSideAuth=0 it then goes in to the endless loading.

 

RE the &clientSideAuth=0 part of the url string:

 

1) It is somehow being added to my url but it isn't for other people?

 

2) It is being added to other people's url too but for some reason it works for them but not me?

 

Thanks!

 

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Fabric Hack Slide Banner

Hack Together: The Microsoft Fabric AI Global Hack

Learn from experts, get hands-on experience, and win awesome prizes.