Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
TheCreepster1
Helper II
Helper II

Azure SQL DB Mirroring Issue

Hi all. I am just looking at testing some of the database mirroring features in Fabric but am currently hitting this error:

 

The database cannot be mirrored to Fabric due to below error: User does not have permission to mirror the database.

 

I am the tenant admin and have enabled Database mirroring for the capacity and tenant for selected security groups, and added a group of which I am a member. I am connecting using a service principal and can see the tables in the database, and select the ones I want to mirror, but when I press mirror it presents the above error message. Anyone any ideas where I'm going wrong?

TheCreepster1_0-1712755402349.png

 

1 ACCEPTED SOLUTION

Hi,

 

I switched the connection credentials to my own, and it worked ok, which narrowed it down to something on the service principal permissions. I've not had the chance to go back and look into it further as something else came up.

View solution in original post

3 REPLIES 3
v-cboorla-msft
Community Support
Community Support

Hi @TheCreepster1 

 

Thanks for using Microsoft Fabric Community.

Apologies for the inconvenience.

The error message that you are encountering typically indicates an issue with the authentication process. Since you aree connecting to an Azure SQL Database, ensure that:

  1. The SQL Server login exists and has the correct permissions.
  2. The password entered is correct. Double-check for any typos or case sensitivity issues.
  3. The Azure SQL Database server's firewall settings allow connections from Microsoft Fabric. You might need to add the IP address of the Microsoft Fabric service to the allowed list. More details on configuring firewall rules can be found here.

The error message you encountered when configuring mirroring suggests that a managed identity for your SQL Server needs to be set up and turned on. Managed identities are crucial for secure, seamless authentication between Azure services.

vcboorlamsft_1-1712821805556.png

For additional information please refer : Enable System Assigned Managed Identity (SAMI) of your Azure SQL logical server

                                                               : Enable Mirroring.

 

I hope this information helps. Please do let us know if you have any further questions.

 

Thanks.

Hi @TheCreepster1 

 

We haven’t heard from you on the last response and was just checking back to see if you have a resolution yet.
In case if you have any resolution please do share that same with the community as it can be helpful to others.
Otherwise, will respond back with the more details and we will try to help.


Thanks.

Hi,

 

I switched the connection credentials to my own, and it worked ok, which narrowed it down to something on the service principal permissions. I've not had the chance to go back and look into it further as something else came up.

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

MayFBCUpdateCarousel

Fabric Monthly Update - May 2024

Check out the May 2024 Fabric update to learn about new features.