Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Reply
Prarav
Regular Visitor

The column 'link' of table not found when report is refreshed

I have reports when I refresh the reports in DEV it is working fine without any errors. However, when I refresh the same report in UAT, it gives the error: The column 'link' of table not found. "Link" is calculated from the column in my table. I check the code and everything looks fine.

I also updated the dev report datasource to UAT but still seeing the same error. I am wondering where am I doing wrong why reports work in DEV but not in UAT.

 

I am stucked and need HEP!!

2 ACCEPTED SOLUTIONS

Thank you for the reply and sorry for the late reply.

 

I checked all the possible troubleshoot steps and did not find any issues. Finally i had to delete the column and dynamically added back. Now it is working. 

Thanks again:)

View solution in original post

Hi @Prarav ,

It's glad to hear that your problem has been resolved. Thanks for sharing your solution here. Could you please mark your post as Answered? It will help the others in the community find the solution easily if they face the same problem as yours.  Thank you.

Best Regards

Community Support Team _ Rena
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

6 REPLIES 6
v-yiruan-msft
Community Support
Community Support

Hi @Prarav ,

Base on your description, it seems like there might be an issue with the data source connection or the table structure in your UAT environment. Could you please check the following things for the further troubleshooting?

  • Check the data source connection: Make sure it’s correctly pointed to the UAT data source and that there are no connectivity issues. You can also try refreshing the data source connection to see if that resolves the issue. 
  • Check the table structure: Make sure that the table structure in your UAT environment matches the table structure in your DEV environment. Check to see if the 'link' column exists in the table and that it has the correct data type.
  • Check the DAX formula: If the 'link' column is calculated using a DAX formula, make sure that the formula is correct and that it is referencing the correct columns in the table.
  • Check the data: Check to see if there are any differences in the data between your DEV and UAT environments. It's possible that the 'link' column is not being populated correctly in your UAT environment due to differences in the data.

Best Regards

Community Support Team _ Rena
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
lbendlin
Super User
Super User

Where is that column created, in DAX or in Power Query?  Power Query is case sensitive, link is not equal to Link.

Thank you for the reply and sorry for the late reply.

 

I checked all the possible troubleshoot steps and did not find any issues. Finally i had to delete the column and dynamically added back. Now it is working. 

Thanks again:)

Hi @Prarav ,

It's glad to hear that your problem has been resolved. Thanks for sharing your solution here. Could you please mark your post as Answered? It will help the others in the community find the solution easily if they face the same problem as yours.  Thank you.

Best Regards

Community Support Team _ Rena
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi 

I am new to this communtiy and it was my first post. I do not see mark as "Answered" button or link anywhere. Could please guide me?

Thanks

Pra

you already marked your reply as solution.  I unmarked all others.  All good.

Helpful resources

Announcements
Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City

PBI_APRIL_CAROUSEL1

Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.