Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
JTY
Frequent Visitor

Streaming dataflow - Azure IoT hub connection

Good day

 

i've created a streaming datalflow dashabord and connected it to Azure iot Hub and it worked, the only issue is how to get the credentials of the iot hub in Azure cause PowerBi service is asking for it. In Azure there is a primary conenction string and not credentails (username and password) 

 

5 REPLIES 5
JTY
Frequent Visitor

JTY_0-1637741933204.png

PBI service is asking for username and password and not string connection 

the connection string worked when editing the streaming dataflow diagram but once im refreshing and pushing play im getting an error that the credentials needs to be updated using a username and a password

v-rzhou-msft
Community Support
Community Support

Hi @JTY 

If you have access to Event Hubs or IoT Hub in your organization's Azure portal and you want to use it as an input for your streaming dataflow, you can find the connection strings in the following locations:

For IoT Hub:

  1. In the Internet of Things section, select All Services > IoT Hubs.
  2. Select the IoT hub that you want to connect to, and then select Built-in endpoints.
  3. Select the Copy to clipboard button next to the Event Hubs-compatible endpoint.

Here is the offical blog about Streaming Dataflow with Azure IoT Hub.

You can learn more about the IoT Hub built-in endpoint in Read device-to-cloud messages from the built-in endpoint.

For reference: Create a streaming dataflow

 

Best Regards,
Rico Zhou

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

please check my reply below 

Hi @JTY 

Could you tell me if your problem has been solved? If it is, kindly Accept it as the solution. More people will benefit from it. Or you are still confused about it, please provide me with more details about your problem.


Best Regards,

Rico Zhou

Hi @JTY 

I found that you use Basic as Authentication Method. Your issue may be caused by Authentication Method.

Make sure your account has access to data soucre and try other Authentication Methods and sign in by your account.

 

Best Regards,
Rico Zhou

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.