Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
StarkPBI
Advocate I
Advocate I

Set your date’s start time so it’s before the end time, then try calling this API again. API Error

This was working last month but now it's not. 

Any ideas?

 

StarkPBI_0-1642485056873.png

 

1 ACCEPTED SOLUTION
v-yiruan-msft
Community Support
Community Support

Hi @StarkPBI ,

It looks like you are using the ActivityEvents API to get the Activity log, and from your screenshot it looks like the startDateTime and endDateTime are in correct  in ISO 8601 compliant UTC formats, and their date ranges are correct. It looks like an issue, I see that you have raised a case in the issue forum, and the support colleague has replied to you: The issue has been reported internally(ICM: 284208185). I will also continue to track the status of this ICM, and I will update you if there is any progress later.

Best Regards

Community Support Team _ Rena
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

8 REPLIES 8
niltu
New Member

Hello, I solved the error by pulling just a specific day and passing the following date format in the api URL.

 

startDateTime='2023-12-03T00:00:00Z'&endDateTime='2023-12-03T23:59:59Z'
lmcconnell1665
Frequent Visitor

@StarkPBI I am having the same issue when I try to get data prior to 30 days ago. 

 

When I try to get data within a 30 day lagging window, the API works as intended.

pvuppala
Helper III
Helper III

Could it be that we can only go back 30days in history?  I am running this call too but it works within 30days.

Yes

metricinsights
Frequent Visitor

@v-yiruan-msft any updates?
Faced the same issue now. 

metricinsights_0-1647356367863.png

Thanks,

v-yiruan-msft
Community Support
Community Support

Hi @StarkPBI ,

It looks like you are using the ActivityEvents API to get the Activity log, and from your screenshot it looks like the startDateTime and endDateTime are in correct  in ISO 8601 compliant UTC formats, and their date ranges are correct. It looks like an issue, I see that you have raised a case in the issue forum, and the support colleague has replied to you: The issue has been reported internally(ICM: 284208185). I will also continue to track the status of this ICM, and I will update you if there is any progress later.

Best Regards

Community Support Team _ Rena
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@v-yiruan-msft Has there been any update on this?  We are also hitting this issue and would like to use the API but the start/ed date issue is blocking us. 

Hi @msalerno, have you fixed the issue ? I have the same problem right now.

Thank you

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.