Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
AndrzejRusin
Regular Visitor

Power BI embedded report - USERNAME() function returns service principal id instead of username

Hi,

We have developed a .Net web application where we embed Power BI reports in the App-Owns-Data scenario, ie. with the use of service principal.

With each request to view a report the embedToken is generated depending on the report metadata, ie. it checks what datasets it is using, whether these datasets require EffectiveIdentity etc. In other words it constructs the token according to the requirements.

In case of mixed-storage reports (composite-models) which are using two or more datasets this token generation used to work fine and we were passing the username parameter in the EffectiveIdentity element to apply the RLS in the datasets, but since recently this functionality stopped working. Normally we used the USERPRINCIPALNAME or USERNAME function to retrieve the username parameter to apply the RLS in DAX, but now in case of mixed-storage reports these functions (USERPRINCIPALNAME, USERNAME and USEROBJECTID) are all returning service principal id (in guid format).

We updated the libraries of the application to use the most up-to-date ones but this gave no effect. Our conclusion is that something was changed in PowerBI Service itself.

It is worth noting that it all works fine in case of reports based on single dataset.

Has anyone run into the same issues recenlty in their embedded solutions?

Best regards,

Andrzej Rusin

4 REPLIES 4
AndrzejRusin
Regular Visitor

Hi @lbendlin 

Thank you for suggestion. We have raised a ticket already. Now we are waiting for response from support, but I was wondering if anyone else encountered such problem.

Hi,

 

There was a general issue in recent 2 weeks related to embedding reports with composite models (with DirectQuery to Power BI dataset). I don't know if the issue you encountered is from the same reason, but AFAIK that issue was resolved by Power BI so maybe you can try testing your scenario again.

Hi @AmosHersch 

Thanks for information. The issue currently still exists on our side, so I think it might have been something else.

lbendlin
Super User
Super User

That doesn't sound good. Since you have a Pro license you can consider raising a Pro ticket at https://powerbi.microsoft.com/en-us/support/pro/

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayPowerBICarousel

Power BI Monthly Update - May 2024

Check out the May 2024 Power BI update to learn about new features.

LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.