Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Regular Visitor

Pbiviz start @ powerbi-visuals-tools@2.5.0


I am following this tutorial to create a custo visual
I recently came across an issue that's preventing me to complete the project.

First of all i completed once, but instead of installing powerbi-visuals-tools@2.5.0 i installed "npm i -g powerbi-visuals-tools", and that led me to a visual that didn't show the forge viewer. So i restarted the process from the beginning.

(here The author says the 2.5.0 is the only version that works

When i installed powerbi-visuals-tools@2.5.0 i had to change my Node.js version from 14.17.6 to 10.8 because the first was not compatible.

What i did next was creating the enviroment following the microsoft tutorial 
npm i d3@^5.0.0 --save
npm i @types/d3@^5.0.0 --save
npm i core-js@3.2.1 --save
npm i powerbi-visuals-api --save-dev (then tried even npm i powerbi-visuals-api@2.5.0)

Then , finally, i came across this issue when running "pbiviz start" in C:\Users\Gian Marco Manfredi\circlecard>


--- note: the issue is different depending on the Node.js i use:

---- version 14.17

info Building visual...
error LESS style/visual.less : The "data" argument must be of type string or an instance of Buffer, TypedArray, or DataView. Received undefined

the visual.less is

p {
    font-size: 20px;
    font-weight: bold;
    em {
        background: yellow;
        padding: 5px;

and the pbiviz.json is

  "visual": {
    "name": "circleCard",
    "displayName": "CircleCard",
    "guid": "circleCardA2677EDA579643169880D5D3DF0E2A32",
    "visualClassName": "Visual",
    "version": "1.0.0",
    "description": "",
    "supportUrl": "",
    "gitHubUrl": ""
  "apiVersion": "2.5.0",
  "author": {
    "name": "",
    "email": ""
  "assets": {
    "icon": "assets/icon.png"
  "externalJS": [
  "style": "style/visual.less",
  "capabilities": "capabilities.json",
  "dependencies": "dependencies.json",
  "stringResources": []

---- version 10.3



I was wondering if the versions of d3@^5.0.0 @types/d3@^5.0.0 core-js@3.2.1 npm i powerbi-visuals-api
were the ringht ones and if not which are the correct ones to use.

Any other suggestion wuold be useful and really appreciated.

Thank you in advantage

Gian Marco



installed typescript @2.3.3 , type/d3@5.7.2 and deleted d3 library

View solution in original post

Community Support
Community Support

Hi @gmmanfredi,

I do not so recommend you to change the prerequisite package version, they may cause compatibility/conflict issues between these different versions.

You can update them to the latest stable and compatibility versions then deploy this project to test and manually fix the issues of package function usages from the different versions.


Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider accept as solution to help other members find it more quickly.

Hi! thank you for answering me!

I've already tried installing the packages at the latest version but didn't work , since the project is built for pbi visual tools 2.5.0. Even upgrading pbiviz@latest the visual remains blank with the error shown here .

As the project author suggests the visual works specifically at the pbiviz 2.5.0 version here 

and here 

My fear is that i have to change something right in the prerequisite packages , maybe even Typescript, but i can't get which is the right version to look for. 

Any suggestion woul be precious

Thank you!


installed typescript @2.3.3 , type/d3@5.7.2 and deleted d3 library

Helpful resources


Fabric certifications survey

Certification feedback opportunity for the community.


Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.