Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

New Member

Images not loading in Chiclet slicers

In my report, I'm using Chiclet slicer with images to slice on Products.

My Product images are in Azure and their path is in an attribute in Product dimension in my cube.


Symptoms of the problem:

1. By default, on the report page, ~30-40 products show up, but images for many of the products don't show up. Only ~6 products show up with images

2. Even though all products show up in the slicer (though some are without images), the slicer shows information icon with message "Too many Values, not showing all data"


Note: Each image is ~5KB in size



Is this a known issue or is there anything specific that I can do to fix it?

Not applicable

In my case Power BI desktop did not show the images correctly but when I published the report it did show up. Also dont forget to change the data category of the URL column to 'Web URL' in the 'Data' tab. Click the 'Data' tab > select the column containing URLs > select Modeling > select Data Category: Web URL (Properties tab).

Frequent Visitor

Chiclet slicer have the problem with the file names containing space. So if you replace the spaces between file name into %20 then it will work for you.

For example


if you have a link like image.jpg

then replace it to


I would suggest replace all spaces containing in url with %20


Hope that helps



This is not working to me either. SO frustating. There are no spaces in my URL. I tried using imgur as source and Google Drive. nothing works.


PLEASE somebody help

Same problem here. And I'm using OneDrive stored images. I can access them fine so it's not network issue.

Community Champion
Community Champion

Do your images require authentication?

Please also note that it'd be better to use HTTPS instead of HTTP.


Ignat Vilesov,

Software Engineer


Microsoft Power BI Custom Visuals

Not applicable

Chiclet slicer loads images from 'http' link correctly. But doesn't load when I use 'https' link. Could anyone advise me how to deal with this issue? Sample https link looks like this: "HTTPS://"  

No they don't and the URL is an HTTPS one

Community Champion
Community Champion

Can you share at least one image link?

I just want to double check that link is correct.


Ignat Vilesov,

Software Engineer


Microsoft Power BI Custom Visuals

Community Champion
Community Champion


This link works well for me.

Could you please open your report with ?unmin=true ( flag and share log from browser's developers tools?


Has this been solved?  I am having this issue today.



Not applicable

Does the image show up whenever you publish the report? Have you tried changing the data category of the URL column to 'Web URL'? 

Hi there, many thanks for the response back.


Sorry I neglected to mentioned I did set to use url, and have tried publishing and image still does not load.


I did try another PBi visual, named Image Grid, and I am still experiencing the same issue.  I feel it is more a user error on my end.

Not applicable

@eamorin96Are the images that you try to view in the slicer public avalaible on the internet? 

Hello everyone,


I ran into same problem and found the fix.


The free icons are not easy to find. I used Now for PBI to display the icon on chiclet slicer you need to provide the embedded html information as below. However, most icon websites do not give you this option readily on the surface unlike



Fix is following

A. Choose your icon from the website.

B. I use Mozilla Firefox. So once you go to the icon page do the following

   From the top menu, select Tools > Web Developer > Page Source

B. look for img src. The embedded html can be found there. Copy paste the embedded html and put that as the URL on the icon dataset and PBI does the rest of the magic.




Have fun guys !!!!


Did I answer your question? Mark my post as a solution!
Proud to be a Super User!
My custom visualization projects
Plotting Live Sound: Viz1
Beautiful News:Viz1, Viz2, Viz3
Visual Capitalist: Working Hrs
Regular Visitor

I am also unable to see Images loading into the Chiclet Slicers.  Is anyone else having this issue?  Is there a way to turn on the rendering?



Not applicable

Im also facing with the same issue.  

I'm having the same issue as well.

Helpful resources

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.


Power BI Monthly Update - May 2024

Check out the May 2024 Power BI update to learn about new features.


Fabric certifications survey

Certification feedback opportunity for the community.