Forum Discussion
Embedding of Reports using Service Principal NOT WORKING for Premium per user
In our current use case we are using the Pro Licence and then embedding the reports published in this account's workspace using service principal to give access to our customers.
With the release of Premium per user we upgraded our Pro Licence to Premium per user. All the reports shared were still working as it is using our Service Principal.
Now problem occurs when we upgrade a workspace to the Premium Capacity with our PPU licence. Now the embedding using service principal breaks giving a '401' error.
Is any one else facing similar issue ??
- Anonymous5 years ago
Hi integrationsupp ,
Sorry for delay. According to the description in this official documentation, Power BI don't support service principals in Premium Per User workspaces currently. You can try to disable the capacity for the related workspace if there is no feature for Premium per user be used...
Best Regards
3 Replies
- AnonymousNot applicable
Hi integrationsupp ,
It seems got unauthorized error... Could you please check whether the related service principal still be listed in Workspace access list with role Member or Admin after upgraded to premium per user?
Add the service principal to your workspace
Best Regards
- integrationsuppFrequent Visitor
hi Anonymous I can cofirm that the service prinicipal is still listed and has Admin rights.
- AnonymousNot applicable
Hi integrationsupp ,
Sorry for delay. According to the description in this official documentation, Power BI don't support service principals in Premium Per User workspaces currently. You can try to disable the capacity for the related workspace if there is no feature for Premium per user be used...
Best Regards