Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
chrismiller
Helper I
Helper I

smart filter not working

Hello,

I am having an issue where smart filter by okviz does not work once my report is published; that is on desktop it works fine, however when I pushlish it the filter is unresponsive. If I switch to a normal powerbi slicer it works.

Has anyone seen this befor?

11 REPLIES 11
cadalano
Frequent Visitor

I am having the exact same issue. Filters work fine on desktop but are sketchy when published

 

They dont seem to actually filter at all, but when you clear the filter out, then suddenly the filter you previously attempted to apply will take place.

 

I'm actually seeing this on non-Smart filter visualis also, like chiclet slicers. Maybe it really is a PBI core problem, as they suggested?

Update from OKViz team: Power BI team told them that a fix will be available in production within 2 weeks

Friday, October 27, 2017

What is the status on this? 
According to the OKviz website, last update on SmartFilter was in August...

 

v-chuncz-msft
Community Support
Community Support

@chrismiller,

 

It works for me. Download and try the latest version 2.48.4792.721.

https://www.microsoft.com/en-us/download/details.aspx?id=45331

Community Support Team _ Sam Zha
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

The developer is looking into it. appearently it is a bug where it doesnt work with internet explorer.

It is behaving wierdly in other browsers too. Sometimes it filters, sometimes it doesn't. Sometimes it keeps the filter on even when the selection is cleared.

I am unable to understand the issue here.

I tried bringing down my account usage from 9gb to 6gb(10 gb account). It worked fine for some time and then again stared behaving wierdly.

I'm having the same type of issues as others. When I select an option in the Smart Filter, nothing happens, when I deslect the option the data then filters by the option I just deselected. It seems very randowm and I've had to replace the "Smart" Filter with a regular slicer

I reached out to OKViz team and they suggested that the issue is from Power BI core. They said they have raised this issue with Power BI team couple of weeks back. No further updates though.

@chrismiller,

 

Thanks for sharing the information.

Community Support Team _ Sam Zha
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@chrismiller@v-chuncz-msft

 

Smart Filter (OKViz) is working for me, BUT it doesn't recognize the aportrophe (') anymore. In the Service nor in the Desktop.

Ex.: "Agents d'encadrement" becomes "Agents dencadrement".

No result when selected.

Paul

i have the same issue with the apostrophes, any alternative to this visual?

Helpful resources

Announcements
Fabcon_Europe_Social_Bogo

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

Top Solution Authors