Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
tkaczmarczyk
Regular Visitor

"Do Not Summarize" missing

I asked a similar question with respect to the Power BI Service recently, but it turns out that I'm experiencing the same issue in the Desktop app.

 

In the documentation, you can find info about being able to treat numeric values as separate rows, without aggregating - a so called "Do not summarize" option: https://support.powerbi.com/knowledgebase/articles/471200-change-the-aggregation-in-a-chart-sum-aver...

 

However, when I'm looking at my own project, with data imported from SQL Azure, I can't seem to find that option anywhere. I reproduced the problem even with a simple Excel sheet as the data source, so it doesn't seem like a bug in the Azure SQL connector : 

 

Capture3.PNG

 

 

If this feature wasn't implement yet or was removed for some reason, how can I find out when to expect it back? The lack of it results in scatter plots being pretty much pointless.

6 REPLIES 6
Anonymous
Not applicable

I was stuck on this issue as well until I found "Default Summarization: Do Not Summarize" under Modeling in PowerBI Desktop

amoine
Frequent Visitor

It is only avaibale in PowerView (ie : Excel)

 

Workaround : flag colum as text in your query

"dirty" workaround : if you need to keep your column as number for other calculation, duplicate the column in your query and flag it as text (remember to order it by the numeric column 😉 )

No longer! You'll now see that option in Power BI Desktop as well!
kcantor
Community Champion
Community Champion

I haven't updated to the latest version and I still have it available in my desktop version. If I go over to the data model and click on one of my measures or on any item with the Sum symbol, I can go up to the top under the Data Tools Tab for Modeling and in the Properties box see "Default Summarization: Sum " with a drop down arrow. Then I click the drop down arrow it offers several aggregations along with the "Do not summarize."

If it is not there for you, it must have been lost in the most recent upgrade.





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!




I can set the Default Summarization to "Don't summarize", but it still doesn't seem to allow a scatter plot that plots every item in a field. When creating a scatter plot with 'don't summarize' default for a field, it defaults to 'count' and 'don't summarize' on the Axis menu isn't there. I'm assuming "don't summarize" isn't supported for lots of specific charts. I can get 'don't summarize' to work on the same data in a table. 

 

Does anyone know how to get it in a scatter plot?

Greg_Deckler
Super User
Super User

I have never seen this in the service or desktop, only in Excel PowerView


@ me in replies or I'll lose your thread!!!
Instead of a Kudo, please vote for this idea
Become an expert!: Enterprise DNA
External Tools: MSHGQM
YouTube Channel!: Microsoft Hates Greg
Latest book!:
Mastering Power BI 2nd Edition

DAX is easy, CALCULATE makes DAX hard...

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Top Solution Authors