Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Resolver III
Resolver III

publishing is complete, however we couldn't refresh your dataset

hi all,

this morning i have modified one of my datasets with the desktop version and after i saved the modifications i published the dataset to the webversion. Before closing the desktopversion, i got the message: "publishing is complete. However we couldn't refresh your dataset". Did a manually refresh with the desktop version which went well, but if i go to the web, i can run "refresh now" but nothing happens. Tried a different dataset and the strange thing is that i managed to update this dataset but others didn t update as well (it does not give any error messages and does not show that you have started a refresh on demand...). Checked the on-prem gateway with the most recent version and they both seems to be the same (both have version 14.16.6584.1).... 

Any ideas what to do???

thanks in advance

Not applicable

Hi there,

I have the same issue, I managed to get a workaround but it's not perfect. 


So I store .pbix file on a SharePoint for a Version Control.

I went to Power BI Service -> Get data -> Files (Get) -> Pointed to my SharePoint location and it successfully published the report. But now I have two reports with same name... so it's not ideal.


I'm also wondering how this issue could be fixed.

View solution in original post

Frequent Visitor

We faced the same issue recently. 


Solution that worked for us :

We changed the workspace settings from Premium to Pro and then published the dashboard which was successful. I believe the issue was with query caching which was On for this particular dataset and its a feature which is available for premium workspace. We reverted to premium workspace and query caching is off now.



Frequent Visitor

For me the issue was with a report that is connected to a Power BI dataset.

I reconnected to the dataset (from Datasource Settings) and this solved the issue

Regular Visitor



i had the same issue. i removed the report and dataset from the service. And i published again. It has published succesfully.




I did this solution and it worked perfectly. 


@attacking wrote:



i had the same issue. i removed the report and dataset from the service. And i published again. It has published succesfully.





I used this solution and it worked for me, too. Thank you! 

Regular Visitor

Is there a solution for this? I am running into this same issue and tried all the workarounds listed above with no success. I have never run into this before and it's currently affecting 4 of my reports. 

Advocate III
Advocate III

This fixed it for me. Editing the credentials. 




same here today, the error came again out of a suddon, for different reports / sources / workspaces. 

Adjusting the workspace is not an option anymore.


In Desktop > data source settings > for all sources changed privacy from "none" to "organizational" - et voila.

This solution worked for me.

Not applicable

We are also facing the same issue. Tried all of the suggested workarounds but non of them solved the issue. 

Not applicable

I tried all the solutions mentioned but no help till now! still facing the same error! can someone please help? 

I was able to solve this by creating a new blank PBIX file of the same name and uploading it (overwriting the existing dataset). Then open up the original pbix and reupload (and overwrite your blank one). This approach retains all of the lineage reports and worked for me. 

Advocate III
Advocate III

We encountered the same issue. Additionally, the service gave this error when trying to refresh online: "The refresh operation failed because it took more than 120 minutes to complete. Consider reducing the size of your dataset or breaking it up into smaller datasets."


We tried the suggestions above but without success. If you have embedded / premium capacity, you could try turning this setting off and on again, this fixed it for us:



Advocate II
Advocate II

We had this issue today, the workarounds didn't work however I found another one..

Clearing Cache did not work, and republishing fresh datasets is not practical as all of the report hyperlinks will change for our consumers.

In the PowerBI Service, I went to



        >Turn on Q&A to ask natural language questions about your data

        >Switch it off via tickbox

You also have to update your .PBIX Desktop file via the following steps, as it will just push the setting back in over the top


        >Preview Features

        >Q&A for Live connected Analysis Services databases

Workaround successful..


Note, I had cleared the QA cache which was over 1GB, however that step in isolation made no difference

Regular Visitor

I encountered similar situation and tried the solutions above but they didn't work.
The solution in my case is related to the permissions.

In Power BI Desktop -> File ->Options and Setting->Data Source Setting
Global Permissions->Edit permissions

Just relogin all the Organization account and problem solved.

This is the only solution I tried and it worked perfectly, thanks!

I had the same issue and this fixed it for me! Very easy fix: one of my data sources was set to anonymous instead of organization sign in--logging in with organizational account fixed it. Thanks! 

Not applicable

Little late to the party but I ran into this issue this morning with one of my reports. I resolved this by deleting the query cache and disabling query caching. 

Not applicable

I have the same issue, except it also won't refresh from the web service. I end up having to delete the report and dataset and re-upload, or publish under a different name. This is a major issue as it creates a break from the reports to all the pinned visuals on the dashboards.


This has happened roughly half a dozen times but only in the last few months, never had this problem before, over the 12m I've been using BI.


The 'Solution' currently given in this topic isn't a workable solution only a workaround which isn't really sustainable.

I was able to solve this by creating a new blank PBIX file of the same name and uploading it. Then open up the original pbix and reupload. This approach retains all of the lineage reports. 

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.


Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors