Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Jmo_1982
Regular Visitor

no 'ok' button to accept a relationship

Hi all,

 

I am experiencing  a problem creating new relationships in Power BI desktop when using direct query to a sql server.

 

I am updating a dashboard I created a few months ago, and when trying to add new data sources and form simple relationships, there is no 'ok' button to accept a relationship of any kind (and yes, I have checked its not hidden on another screen!)

Jmo_1982_0-1719885257773.png

I have

  • tried restarting my laptop
  • confirmed am on the latest version:  2.130.930.0
  • confirmed no firewall issues
  • created a blank dashboard and attempted to recreate old relationships - still no ok button
  • created a blank dashboard and attempted to recreate new relationships - still no ok button
  • confirmed there are no nulls, blanks or duplicate values in the first data set.

I can see that someone posted a similar problem, but those troubleshooting steps did not solve my issue: Solved: Can't create a table relationships - Microsoft Fabric Community

Any help would be greatly appreciated - I have never had this issue before!

 

1 ACCEPTED SOLUTION
Jmo_1982
Regular Visitor

In case anyone else has this issue - it ended up being a UI bug which some very helpful microsoft reps helped me work through. The fix involved tabbing to where the 'ok' button should be and hitting enter. 

View solution in original post

13 REPLIES 13
Jmo_1982
Regular Visitor

In case anyone else has this issue - it ended up being a UI bug which some very helpful microsoft reps helped me work through. The fix involved tabbing to where the 'ok' button should be and hitting enter. 

Ritaf1983
Super User
Super User

Hi @Jmo_1982 

If the issue isn't related to the position of the relationships pane being too low and the import mode is Import.
I would try the autodetect option.

Ritaf1983_0-1719891923544.png

 


If that doesn't work either, I would uninstall and reinstall the desktop version, because there is no some general bug...

If this post helps, then please consider Accepting it as the solution to help the other members find it more quickly

Autodetect fails to recognise any relationships, though when I try to create a very simple PatientId:PatientId relationship, it does correctly detect this is a one:many relationship.

I uninstalled and reinstalled and it hasn't changed: it's just... not there and I am absolutely baffled

Jmo_1982_0-1719894335466.png

 

@Jmo_1982 

So there seems to be some logical issue. Where are your tables coming from?

+

I attached a PBIX of mine, try to remove and create relationships, and check if it works differently.

I deleted the relationship between product ID and product ID and tried to reinstate the relationship.... there is no ok button. What is going on!?

 

My tables are coming from a direct query to a sql server, but given the same problem is happening with the imported data in your set, this seems to be a Pbi desktop issue... any suggestions for fixing this, given I have already uninstalled and reinstalled?

Hi @Jmo_1982 

Try to change the import mode to "dual".

There is no option to change the import mode to dual - assuming my googling is correct and this is where it is supposed to be - in properties. This is the case for your data set as well as mine 

Jmo_1982_0-1719975751632.png

 

Hi @Jmo_1982 
Import mode is on the table level :

Ritaf1983_0-1719976168218.png

**** This will not work with my pbix because it is a data source from Excel

Thank you - I managed to changed it to dual but there is still no 'ok' button to accept a relationship (or autodetect). Do you have any other ideas? I really appreciate the help.

Unfortunately, no. If it works on your file and works on mine, it means the issue is likely specific to your data.

Without access to your file, I'm afraid I cannot determine the exact cause.

At this point, it's probably best to open a support ticket with Microsoft.

https://learn.microsoft.com/en-us/power-bi/support/create-support-ticket

 

Thanks so much for trying - I really appreciate the help. Unfortunately I can't send through patient data, but I will open a ticket. Have a great day 🙂

Jmo_1982
Regular Visitor

Hi Greg, 

 

Sorry if I wan't clear - there is no ok button. At all. Not even hidden on another page! 

 

Jill

Greg_Deckler
Super User
Super User

@Jmo_1982 Maybe adjust screen resolution?


Follow on LinkedIn
@ me in replies or I'll lose your thread!!!
Instead of a Kudo, please vote for this idea
Become an expert!: Enterprise DNA
External Tools: MSHGQM
YouTube Channel!: Microsoft Hates Greg
Latest book!:
The Definitive Guide to Power Query (M)

DAX is easy, CALCULATE makes DAX hard...

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

Top Solution Authors