Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
space83
Helper IV
Helper IV

expand all nodes in decomposition tree

below is my decomposition tree. any ideas how can i expand all the tree in production file untill CP3 without need to click every single nodes?

 

Untitled.jpg

1 ACCEPTED SOLUTION
Pragati11
Super User
Super User

Hi @space83 ,

 

I tried creating the decomposition chart, I expanded every single node and saved my pbix file. When I open again, my decomposition tree shows all the nodes expanded by default:

Pragati11_0-1611655636583.png

 

I have got the follwing settings under formatting for this visual:

Pragati11_1-1611655705915.png

 

Thanks,

Pragati

Best Regards,

Pragati Jain


MVP logo


LinkedIn | Twitter | Blog YouTube 

Did I answer your question? Mark my post as a solution! This will help others on the forum!

Appreciate your Kudos!!

Proud to be a Super User!!

View solution in original post

8 REPLIES 8
MustafaElkarim
New Member

can i see you table relation cuz i have same strucher for data with break down and the breaksdown take the same value of the previous breakdown

RKM
Helper IV
Helper IV

Apologies for posted on old thread. Did you really get an answer here?

The one marked as solution, seems just one level but you in your question have asked how to expand all upto CP3 - means almost upto 5th level of drill. I doubt in Power Bi currently it is possible. 

 

@Pragati11 : Could you please review again, in case you found a solution to keep all elements shows for more than 1 level, could you kindly share the solution / pbix

ya, actually i dont got my answer and i dont want stuck much time with this issue.

This report also not used in my organization.

 

Pragati11
Super User
Super User

Hi @space83 ,

 

I tried creating the decomposition chart, I expanded every single node and saved my pbix file. When I open again, my decomposition tree shows all the nodes expanded by default:

Pragati11_0-1611655636583.png

 

I have got the follwing settings under formatting for this visual:

Pragati11_1-1611655705915.png

 

Thanks,

Pragati

Best Regards,

Pragati Jain


MVP logo


LinkedIn | Twitter | Blog YouTube 

Did I answer your question? Mark my post as a solution! This will help others on the forum!

Appreciate your Kudos!!

Proud to be a Super User!!

I guess you might have missed the point raised in the Original Question. @space83 talked about multiple levels.. i.e. more than 2.

What you designed is only level 2. Try to have another level after 'Category' and then try to expand all of the nodes, you'll see the problem.

Hello, you said you expanded every node, but looking at your screenshot, it doesn't seem to be the case. Did you really expand on every node? Just came across this thread as I am experiencing the same issue right now. 

Hi @wgjunsay , Did you ever get an answer or figure out how to have all nodes expanded on your Decomposition Tree? I am also experiencing this issue and trying to find a solution.

 

Thanks,

Janet

Hello @jamoroso unfortunately I haven't. It seems to be a limitation to the visual. 

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.