Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
mvarma
Regular Visitor

We cannot convert the value null to type table

We are trying to load the table using direct query mode and always gets this error. The table is not empty but still gets this error in both query editory as well from the get Data. Please let us know how to resolve this issue.

8 REPLIES 8
leestott
Regular Visitor

Hi if your getting this error when trying to connect to a data source

ErrorPowerBi.GIF

Unable to connect 

We encountered an error while trying to connect 

Details: "We cannot convert the value to type Logical."

 

To fix this follow the following steps 

 

Step 1. Press Cancel on the Error

Step 2. Select Get Data from the ribbon 

Step 3. Select More 

Step 4. Choose Other -> Blank Query 

Step 5. Click Connect 

Step 6. A new PowerQuery Editor will open 

Step 7. Select the view from the menu 

Step 8. Select advanced editor 

Step 9. In the advanced editor query add  ,null to  the end of your connection string previously used 

 

##Example - connecting to an azure data lake## 

 

let
    Source = DataLake.Contents("adl://data.azuredatalakestore.net/local_data/", null)
in
    Source

 

Step 10 Click Done

Step 11 The data will now load

mithsm10
New Member

Had a similar issue. Saw the recommendations in https://community.powerbi.com/t5/Desktop/We-cannot-convert-the-value-null-to-type-Table/td-p/391064, and after upgrading my PowerBI version the error was resolved. 

Dandelion0124
Frequent Visitor

Hi, 

Have you solved your problem? Because we also met the same problem when trying to load table to power bi using direct query from the clickhouse odbc. The table have no null values but power bi always give that "We can not convert the value null to type table". So I think maybe the same problem with you. 

Great thanks if you have suggestions

dleonardi
Frequent Visitor

We're getting the same error as mvarma with the Impala connection.  However, the DQ connection to Impala worked properly in workbooks we created in the past, and such existing workbooks still function properly.  But if we create a new worbook and try to create a new DQ Impala connection, we get this same 'null to type table' error.  A preview of the table successfuly renders in the data/query step, but we cannot "close and apply" without encountering the error.  We did just update to Power BI Desktop to 2.54.4970.961, so perhaps a bug introduced in a recent release?  It had been a few months since our last update to PBI Desktop.

v-chuncz-msft
Community Support
Community Support

@mvarma,

 

Share more information if convenient. You may check each step in The Advanced Editor.

Community Support Team _ Sam Zha
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I am trying to upload a table from impala to PowerBI. From the GetData button I choose impala and then connect to the impala and choose the database and then the desired table and click load. And it tries to load the table and fails with the error message "We cannot convert the value null to type table". I tried opening up the "Edit Queries" button and loading the table from there by clicking the apply and close button once the table is opened in editor, there also the same error appears. This is not specific to table, I tried several table and the same error appears.

Appreciate your help on this at the earliest.

@v-chuncz-msft appreciate your help on this 

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.